US and Worldwide: +1 (866) 660-7555
Results 1 to 3 of 3

Thread: Virtual cube Error

  1. #1
    Join Date
    Aug 2013
    Posts
    127

    Default Virtual cube Error

    hello

    I have created a cube with fact table view which has joined with total hierarchy, created share dimensions work fine

    then created a second cube of raw materials with fact view joined on with total hierarchy works fine

    now created a virtual cube combining both. say for example i need to display total power consumed(from first cube) for the raw material crushed on for particular day for the hierarchy.
    both actual fact table has the field in common is the last field in the hierarchy table

    In virtual cube the analysis work fine for the parameters of individual cube, but when i tried to do cross analysis (fact1 to dim 2 or viceversa or dim1 dim2 fact1 fact2) it's not working

    Thank u for ur time
    pentaho enthusiast
    suresh

  2. #2
    Join Date
    Jan 2013
    Posts
    512

    Default

    Not sure if this is what you're hitting, but one thing to keep in mind is that in a virtual cube, dimensions that don't join to a particular base cube will produce empty results for that cube's measures. For example, Crossjoining members of the customer dimension with [Warehouse Sales] in [Warehouse and Sales] will produce null results, since [Customer] is inapplicable to [Warehouse Sales].
    It's common in virtual cubes to use the ValidMeasure() in calculations to specially handle cases where you have non-joining dims in an analysis. ValidMeasure() essentially forces all inapplicable dimensions to the All level, so you can still get values in cross-cube analysis.

  3. #3
    Join Date
    Aug 2013
    Posts
    127

    Default

    Thanks a lot Mcampbell your are a great support
    that worked along with a small change
    actually the dimension name in both cube are differ by case sensitive

    Thanks for ur time every one
    Pentaho enthusiast
    suresh

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •