US and Worldwide: +1 (866) 660-7555
Results 1 to 4 of 4

Thread: Schema Workbench - Saiku - UTF8 problem

  1. #1
    Join Date
    May 2014
    Posts
    9

    Default Schema Workbench - Saiku - UTF8 problem

    Hi everybody,

    i was trying to create a mondrian cube in Pentaho Schema Workbench (Product Version : 3.6.1) but because I need to change the returned values of the data (sex1 = "ΜΑΝ" sex2 = "WOMAN"), I use a key expression with SQL value as you can see below
    schema1.jpgschema2.png


    The only problem is that i use as returned values strange characters (the Greek characters).

    So when I publish to Pentaho (Version 5.0 CE) although in JPIVOT i get the right results with the right characters, in PIVOT4J (Version 0.9) and SEIKU (Version 2.6) get both in result grid and charts strange characters...

    I have already change workbench.bat (-Dfile.encoding="UTF-8")
    "%_PENTAHO_JAVA%" -Xms100m -Xmx500m -cp "%CP%" -Dfile.encoding="UTF-8" -Dlog4j.configuration=file:///%ROOT%\.schemaWorkbench\log4j.xml mondrian.gui.Workbench

    and start-pentaho.bat (-Dfile.encoding="UTF-8")
    IF "%BITS%" == "64" (
    set CATALINA_OPTS=-Xms1024m -Xmx2048m -XX:MaxPermSize=256m -Dfile.encoding="UTF-8" -Dsun.rmi.dgc.client.gcInterval=3600000 -Dsun.rmi.dgc.server.gcInterval=3600000
    ) ELSE (
    set CATALINA_OPTS=-Xms256m -Xmx768m -XX:MaxPermSize=256m -Dfile.encoding="UTF-8" -Dsun.rmi.dgc.client.gcInterval=3600000 -Dsun.rmi.dgc.server.gcInterval=3600000
    )


    Who is responsible for this ??? (Plugins ??)

    Is something i must change in Pentaho or in Plugins so to read UTF-8 characters??

    Thanks in advance
    Kostas

  2. #2
    Join Date
    Sep 2012
    Posts
    22

    Default

    Hi,

    I suspect it might be related to this issue : http://jira.pentaho.com/browse/MONDRIAN-1826

    I find it surprising that it's working alright with JPivot, as the issue should affect all plugins which uses that version of Mondrian.

    But anyway, in case if the problem is indeed the same one as this issue, then I believe this should be fixed in the upstream.

    Regards,
    Xavier

  3. #3
    Join Date
    May 2014
    Posts
    9

    Default Schema Workbench - UTF8 problem

    Further to your reply and testing some situations I have found that the problem occurs also without publishing the cube to Pentaho..
    If i opened a NEW MDX Query inside Workbench and write down the Query

    select {[Measures].[count]} ON COLUMNS,
    {[Gender].Children} ON ROWS
    from [cube_panos14]

    it will return
    Axis #0:
    {}
    Axis #1:
    {[Measures].[count]}
    Axis #2:
    {[Gender].[GYNAIKA]}
    {[Gender].[ᅫムᅫンᅫヤᅫ괘ムᅫᆪ]}
    Row #0: 72
    Row #1: 78


    So no connection yet with Pentaho BI Server and Other plugins... The problem is from Workbench or the construction of the cube.

    Any ideas ??

    Kostas


    Quote Originally Posted by mysticfall View Post
    Hi,

    I suspect it might be related to this issue : http://jira.pentaho.com/browse/MONDRIAN-1826

    I find it surprising that it's working alright with JPivot, as the issue should affect all plugins which uses that version of Mondrian.

    But anyway, in case if the problem is indeed the same one as this issue, then I believe this should be fixed in the upstream.

    Regards,
    Xavier

  4. #4
    Join Date
    May 2014
    Posts
    9

    Default

    After a lot of tests I beleive that is mondrian library problem.

    Even without schema workbench, by using only data source wizard inside Pentaho 5.0 CE .. i wrote in Data source wizard a SQL
    SELECT _URI "COUNT",
    CASE GENDER
    WHEN 'sex1' THEN 'Άνδρας'
    WHEN 'sex2' THEN 'WOMAN'
    END "Gender"
    FROM EXHIBITION

    which returns the records (in Preview) all right. But when I've tried to open them inside OPENI or SAIKU i get wrong characters ...

    Any Ideas ???
    Kostas

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •