US and Worldwide: +1 (866) 660-7555
Results 1 to 5 of 5

Thread: Getting information back from an embedded transformation

  1. #1
    Join Date
    Feb 2017

    Unhappy Getting information back from an embedded transformation


    I have a transformation that calls another transformation to do some recursion on a result set (since looping is not an option). I pass an XML from the parent transformation to the child transformation. I then do some processing in the child and put together a string that I need to pass back to the parent. How can I do this? I tried using "result rows" with the field specified there, but I'm not sure if I'm missing something. I get an "undefined" error when trying to use it in the parent transformation.

    Any help is greatly appreciated.


  2. #2


    Are you using a "Copy rows to Results" step at the end of the subtransformation?

  3. #3
    Join Date
    Feb 2017


    Quote Originally Posted by Isha Lamboo View Post
    Are you using a "Copy rows to Results" step at the end of the subtransformation?
    Yes.This is what I have.
    Parent transformation:
    Parent transf.jpg

    Child transformation settings
    child transf call.jpg

    Child transformation (the first step I get rows from result)
    child transformation.jpg

    This is the step where I put together the string.
    child step.jpg

    After the child transformation runs, I try printing out the result row
    print out result value.jpg

    If I don't initialize that field in my parent transformation, then I get an error "Reference Error: "timesheetEntryXML" is not defined". If I define it in the js step before the child transformation, then I just get that initial value back (it's not updated with the string from the child transformation).

    Am i missing something?

    Thanks for your help. I've spent already a lot of time on this and can't figure it out..

  4. #4


    Looking through your transformation, I'm not sure why you define timesheetEntryXML in the "Get rows from results" step in your child transformation, as it doesn't (need to) exist at that point. This is probably where the reference error comes from.

    In your screenshot of the Script values/mod step (where you put the string together), I don't see either the variable or an output field defined.

    Try adding this to the first line:
    var timesheetEntryXML = new String();
    and define the field timesheetEntryXML with type String as an output field to add it to the stream. This last thing is probably the missing piece in your puzzle.
    Last edited by Isha Lamboo; 02-17-2017 at 10:52 AM.

  5. #5
    Join Date
    Feb 2017


    That worked!!! I thought I had already tried that, but I guess I hadn't.. Thanks so much for your help!

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts