Hitachi Vantara Pentaho Community Forums
Results 1 to 8 of 8

Thread: Report Configuration

  1. #1
    Join Date
    Aug 2016
    Posts
    7

    Default Report Configuration


    Hi everyone,I'm working with a report with date type parameters. When I publish this report to Pentaho BI, the fields load, as the amount of dates is large it weighs the fill time. The question is, is there a way to remove this auto complete?

    Another question, it is possible to remove the message "This prompt value is of an invalid value"
    Attached example.

    Thanks
    Autocomplete.jpg

  2. #2
    Join Date
    Nov 2009
    Posts
    550

    Default

    The message "This prompt is of an invalid value" comes because you have checked the option "Validate Values" in the parameter
    To remove the auto completion. Go in the report designer to the "Attribute" tab of the master report and change the auto-submit option for the parameter to false

  3. #3
    Join Date
    Aug 2016
    Posts
    7

    Default

    Thanks johanhammink for the answer, but the auto complete continue showing the options even performing the procedure mentioned. To be clear, I want to remove the loading of field information.

  4. #4
    Join Date
    Aug 2006
    Posts
    274

    Default

    The auto-complete is enabled if the parameter is driven by a query; can you try removing such a query

  5. #5
    Join Date
    Aug 2016
    Posts
    110

    Default

    Perhaps use the Date Picker type for the parameter? I use this all the time and for dates and I have no loading issues

  6. #6
    Join Date
    Aug 2016
    Posts
    7

    Default

    Quote Originally Posted by caralomi View Post
    The auto-complete is enabled if the parameter is driven by a query; can you try removing such a query
    I'm using the query to distinct dates, can't remove the query.

  7. #7
    Join Date
    Aug 2016
    Posts
    7

    Default

    Quote Originally Posted by Deanicus View Post
    Perhaps use the Date Picker type for the parameter? I use this all the time and for dates and I have no loading issues
    I tryed but doesn't work, cause the field of my date recognizes like a string value. Only with Text Box works. Any suggestion?

  8. #8
    Join Date
    Aug 2016
    Posts
    110

    Default

    Quote Originally Posted by MateusDido View Post
    I tryed but doesn't work, cause the field of my date recognizes like a string value. Only with Text Box works. Any suggestion?
    Use a date picker parameter for the user to use then create a hidden string parameter with this post processing formula =TEXT(DATE(YEAR([Date_Picker]);MONTH([Date_Picker]);DAY([Date_Picker]));"yyyy-MM-dd") where Date_Picker is the name of the date picker parameter you just created

    You should then be able to pass this parameter to your query

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2017 Pentaho Corporation. All Rights Reserved.