US and Worldwide: +1 (866) 660-7555
Results 1 to 9 of 9

Thread: Problem with parameter post-processing on 7.1 BI Server but not PRD

  1. #1
    Join Date
    Jun 2017
    Posts
    5

    Default Problem with parameter post-processing on 7.1 BI Server but not PRD

    Hi all,

    I think I may be experiencing a bug in BI Server 7.x. I have a parameter that is tied to a date picker prompt. There is post-processing being performed in order to append the time 23:59:59 to the date chosen. The functionality works fine in BI server 6.x as well as Report Designer 6 and 7.1 It seems similar to this bug but this one was listed as fixed in 7.1 --> http://jira.pentaho.com/browse/BISERVER-13504

    The post processing looks like this:

    =DATETIMEVALUE(DATE(YEAR([inputenddate]);MONTH([inputenddate]);DAY([inputenddate]))+TIMEVALUE("23:59:59"))

    All is well in 6 BI server but in 7.0 and 7.1 when that date picker is used to select a date the report is never returned and instead the user is presented with what appears to be a rapid loading of the report, the progress indicator and the original prompt form page. It appears like flashing and never stops.

    In order to simplify things I changed the post processing to just add a full day:

    =DATEVALUE([inputenddate] + 1)

    Same result.

    I decided to try post processing that wouldn't really do anything:

    =DATEVALUE([inputenddate] + 0)

    It works fine.

    I'm happy to submit a bug but thought I'd get the forum's opinion on this first.

    Thanks!

  2. #2
    Join Date
    Jun 2017
    Posts
    5

    Default

    Since originally posting this I believe I've further narrowed down the problem to post processing that is self-referential. The above post-processing is occurring in the settings for the inputenddate parameter itself. Again, this was fine in 6.0 BI server and works in 7.1 RPD but not 7.1 BI server. I am working around the issue by using an additional hidden parameter to do the post-processing and using that in my sql queries which solves the problem.

    I can see arguments for not allowing the post-processing on a parameter to reference itself but it was handy and I'm wondering what the desired behavior is.

    Thanks!

  3. #3
    Join Date
    Aug 2006
    Posts
    246

    Default

    Thank you for the steps I have written the following bug

    http://jira.pentaho.com/browse/BISERVER-13663 - Post Processing Formula that references same parameter goes into a loop and it never stops

  4. #4
    Join Date
    Jun 2017
    Posts
    5

    Default

    Thank you!

  5. #5
    Join Date
    Nov 2009
    Posts
    502

    Default

    Is "auto submit" enabled ? And when yes is it also going into a loop if you disable it?

  6. #6
    Join Date
    Jun 2017
    Posts
    5

    Default

    The behavior is the same regardless of "auto-submit" state.

  7. #7
    Join Date
    Aug 2006
    Posts
    246

    Default

    The problem is with the post-processing formula note the jira has been updated to reflect that it impacts self-reference parameters as well as other parameters

    http://jira.pentaho.com/browse/BISERVER-13663 - Report with Post Processing Formula that references another parameter or itself goes into a loop and it never stops

  8. #8
    Join Date
    Jun 2017
    Posts
    5

    Default

    Quote Originally Posted by caralomi View Post
    The problem is with the post-processing formula note the jira has been updated to reflect that it impacts self-reference parameters as well as other parameters
    Interesting. I have successfully worked around the problem on all of our reports that had self-referencing post-processing by creating an additional parameter and referencing that parameter instead. That was 7.1.

    Cheers

  9. #9
    Join Date
    Aug 2006
    Posts
    246

    Default

    brianrieck
    FYI:
    Looks like there is another issue that resulted from this behavior:
    http://jira.pentaho.com/browse/BISERVER-13677

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •