US and Worldwide: +1 (866) 660-7555
Results 1 to 3 of 3

Thread: Email.ERROR_0011 - SMTP send failed

  1. #1
    Join Date
    Mar 2007
    Posts
    1

    Default Email.ERROR_0011 - SMTP send failed

    G'Day,

    I have installed PCI (1.2.0.534-GA) and changed the email config file email_config.xml. I restarted the server but every time I want to test a burst report I get the error messages:

    Error: Email.ERROR_0011 - SMTP send failed: [joe@pentaho.org] - javax.mail.SendFailedException: Sending failed; nested exception is: class javax.mail.AuthenticationFailedException (org.pentaho.plugin.email.EmailComponent)
    Error: RuntimeContext.ERROR_0012 - ActionDefinition for org.pentaho.component.EmailComponent did not execute successfully (org.pentaho.core.runtime.RuntimeContext)
    Error: SolutionEngine.ERROR_0007 - Action sequence execution failed (org.pentaho.core.solution.SolutionEngine)

    Apart from this it seems that joe@pentaho.org is hard coded.
    Please let me know how I can fix the error. The customer is waiting for a presentation.
    Thank you.

  2. #2
    gmoran is offline Pentaho Enterprise Architect / Technical Account Manager
    Join Date
    Nov 1999
    Posts
    324

    Default

    First, you should test your email send capabilities using the Test Email Sample under Getting Started in the Pentaho Demo Samples. This will clear the trees for you.

    Next, the exception you are receiving is a javax.mail.AuthenticationFailedException, which leads me to believe you may have the wrong password for the user name you have specified.

    And last, in the email_config.xml, the joe@pentaho.org that you reference is setting the default value of the "from" field on the email, not the account by which the mail is being sent. Some SMTP servers do want a valid "from" email address, however. Valid meaning an account that the SMTP server recognizes as one of its own. It's perfectly acceptable to change the value of that parameter.
    kind regards,
    Gretchen
    Pentaho SME & Community Member

  3. #3
    Join Date
    Aug 2009
    Posts
    25

    Default

    Hi,

    I opend a similar thread and didn´t get a hint:
    http://forums.pentaho.org/showthread...ail_config.xml

    Could you find a solution?

    I have tried it since one week to send a report as an email.
    But unfortunately without success.

    In my opinion the properties of the email_config.xml file is wrong.

    It would be a pleasure if you could give me a hint.

    Thank you.

    Bye
    ManInBlack


    email_config.xml:
    Code:
    <email-smtp>
    
      <!-- The values within <properties> are passed directly to the JavaMail API.
           For a list of valid properties see http://java.sun.com/products/javamail/javadocs/index.html -->
        <properties>
            <!-- This is the address of your SMTP email server for sending email. e.g. smtp.pentaho.org -->
            <mail.smtp.host>mail.gmx.net</mail.smtp.host>
    
            <!--  This is the port of your SMTP email server. Usually this is 25. For GMail this is 587 -->
            <mail.smtp.port>25</mail.smtp.port>
            
            <!--  The transport for accessing the email server. Usually this is smtp. For GMail this is smtps -->
            <mail.transport.protocol>smtp</mail.transport.protocol>
            
            <!--  Usually this is 'false'. For GMail it is 'true' -->
            <mail.smtp.starttls.enable>false</mail.smtp.starttls.enable>
            
            <!-- Set to true if the email server requires the sender to authenticate -->
            <mail.smtp.auth>true</mail.smtp.auth>
            
            <!--  This is true if the email server requires an SSL connection. Usually 'false'. For GMail this is 'true' -->
            <mail.smtp.ssl>false</mail.smtp.ssl>
    
           <!--  Output debug information from the JavaMail API -->
           <mail.debug>true</mail.debug>
    
        <!-- For GMail this is 'false' -->
        <!--mail.smtp.quitwait>false</mail.smtp.quitwait-->
    
        </properties>
    
        <!-- The is the address of your POP3 email server for receiving email. e.g. pop.pentaho.org -->
        <!-- It is currently not used -->
        <mail.pop3>pop.gmx.net</mail.pop3>
    
        <!-- This is the default 'from' address that emails from the Pentaho BI Platform will appear to come from e.g. joe.pentaho@pentaho.org -->
        <mail.from.default>testuser@gmx.com</mail.from.default>
    
        <!-- This is the user id used to connect to the email server for sending email
           It is only required if email-authenticate is set to true
           This is never sent or shown to anyone -->
        <mail.userid>123456789</mail.userid>
        
        <!-- This is the password used to connect to the email server for sending email 
           It is only required if email-authenticate is set to true
           This is never sent or shown to anyone -->
        <mail.password>password123</mail.password>
    
    </email-smtp>
    (I changed my properties (emailadress, userid, password) because of security-aspects, but the test-data show you
    what I typed in)
    Last edited by ManInBlack; 09-08-2009 at 08:43 AM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •