US and Worldwide: +1 (866) 660-7555
Results 1 to 3 of 3

Thread: Query with parameter - Report Designer

  1. #1

    Default Query with parameter - Report Designer

    Hello, How I can create a parameterized query using the data source metadata.xmi?

    I have already created the query and the parameter(called param_1), as I can associate?

    Example
    in the query editor I have:

    field1 = param_1

    Does not work, I also used $ param_1, {$param_1}.

  2. #2
    Join Date
    Mar 2008
    Posts
    353

    Default

    usually it should work like this:

    <condition>
    [TABLE.field1] = [paramaram_1]
    </condition>

    but if you use the query designer it seem like it is always putting quotes around it like
    [TABLE.field1] = "[paramaram_1]" which does not work.

    so you have to manually enter the param into the xml query, right?

    edit: I have to correct myself....
    in the query editor under Value you can enter your parameter in brackets like {param_1} (without $), then it is translated into
    [TABLE.field1] = [paramaram_1] in the query-xml
    Last edited by mgie; 01-28-2010 at 06:33 AM.

  3. #3

    Default

    Quote Originally Posted by mgie View Post
    usually it should work like this:

    <condition>
    [TABLE.field1] = [paramaram_1]
    </condition>

    but if you use the query designer it seem like it is always putting quotes around it like
    [TABLE.field1] = "[paramaram_1]" which does not work.

    so you have to manually enter the param into the xml query, right?

    edit: I have to correct myself....
    in the query editor under Value you can enter your parameter in brackets like {param_1} (without $), then it is translated into
    [TABLE.field1] = [paramaram_1] in the query-xml
    Thank you mgie, your help is always precious.

    You can help me in publishing the report on the server?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •