US and Worldwide: +1 (866) 660-7555
Results 1 to 7 of 7

Thread: Unexpected problem reading shared objects from XML file : null

  1. #1
    Join Date
    Apr 2012
    Posts
    3

    Default Unexpected problem reading shared objects from XML file : null

    when I begin a new transform or job,it puts the errors:



    Unexpected problem reading shared objects from XML file : null


    Error reading information from input stream
    Invalid byte 2 of 2-byte UTF-8 sequence.



    and then,I can still begin a new transform,but when I save it ,the error appears again,and can not be executed correctly.
    I had not change any parameters,how can this error occur??

    many thanks
    Attached Images Attached Images

  2. #2
    Join Date
    Apr 2012
    Posts
    3

    Default

    anybody knows? thanks

  3. #3
    Join Date
    Apr 2009
    Posts
    21

    Default

    see http://wiki.pentaho.com/display/EAI/.17+Shared+Objects for more information on shared objects.

    I can generate a similar error when I manually corrupt my shared objects-file (~/.kettle/shared.xml)
    When I change the file from within PDI (mark another step as shared in View), a fresh and correct file is written immediately.


    I suggest you locate your shared.xml, open it in a decent xml-editor and try to locate the offending character(s).
    You can probably move the file to make the errors disappear - but then you lose the shared objects you already selected.


    good luck,
    Thijs Verhagen

  4. #4
    Join Date
    Apr 2012
    Posts
    3

    Default

    thank you,
    but I didn't find the "shared.xml", only find these which like "shared":
    D:\pdi-ce-4.2.0-stable\data-integration\docs\api\org\pentaho\di\shared\
    D:\pdi-ce-4.2.0-stable\data-integration\docs\api-core\org\pentaho\di\shared\
    D:\pdi-ce-4.2.0-stable\data-integration\docs\api\org\pentaho\di\shared\class-use\SharedObjects.html
    D:\pdi-ce-4.2.0-stable\data-integration\docs\api\org\pentaho\di\shared\SharedObjects.html
    D:\pdi-ce-4.2.0-stable\data-integration\docs\api-core\org\pentaho\di\shared\class-use\SharedObjectBase.html
    D:\pdi-ce-4.2.0-stable\data-integration\docs\api-core\org\pentaho\di\shared\class-use\SharedObjectInterface.html
    D:\pdi-ce-4.2.0-stable\data-integration\docs\api-core\org\pentaho\di\shared\SharedObjectBase.html
    D:\pdi-ce-4.2.0-stable\data-integration\docs\api-core\org\pentaho\di\shared\SharedObjectInterface.html


    I had re-download the spoon,and open it ,the errors react,so I think maybe I had some system variable error??

  5. #5
    Join Date
    Apr 2009
    Posts
    21

    Default

    This file is part of user-settings, not of the installation.

    On my system I have a folder named .kettle in ${user.home}.
    Turn on Show hidden files in your filemanager to see this folder.

    Or try using Show file content on Text file input with File or directory set to ${user.home}/.kettle/shared.xml.
    (tooltip on MouseOver in the edit-field shows the value of filename)

  6. #6
    Join Date
    Dec 2012
    Posts
    1

    Default

    HI,

    i got the same problem as like you got , now it is solved. solution for to get rid off these type error is

    just go to 'Edit' option in menu bar and in that 'edit' option goto 'edit the kettle.propertes file' option and then give 'kettle_shared_objects' value is '50'.

    just try it once,let me know ..

    rgds,
    uppi

  7. #7
    Join Date
    Jul 2016
    Posts
    1

    Default

    Hi,
    I had the same error and solved changing the KETTLE_SHARED_OBJECTS.

    So to do this go to C:\Users\xxxx\.kettle than open file repositories, and set KETTLE_SHARED_OBJECTS=50

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •