View Full Version : Pentaho Data Integration [Kettle]

Pages : 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 [97] 98

  1. Possible to upgrade Janino to support newer java versions?
  2. converting to timestamp
  4. Call endpoint Step - Problem with PUT method
  5. 'Abort on Error' or 'Error Handling' options not working in Vertica bulk loader
  6. Regular Expression Evaluation - trouble
  7. Microsoft Excel Writer
  8. DI Salesforce intergration stopped working today - really need help
  9. Error handling in Vertica bulk loader
  10. Modified Javascript Step - please help
  11. Timing issue in Execute SQL Statement?
  12. how to lock and increment a variable ot prevent data race
  13. Set CSV Input process one by one row
  14. How to set connection option globally?
  15. Output CSV file size issue
  16. Variables frustration
  17. Evaluate number of rows in a table step
  18. Set Variable and Get Variable in same transformation
  19. Filtering lines between an header and a footer in a multirecord file
  20. Pentaho variable in SQL script?
  21. pdi regular expression if else scenario (or capture groups)
  22. PDI 7.1 XML return ok - PDI 8.0 XML bad return
  23. Dynamic column in CSV file
  24. Upload zip file object to blob field in database
  25. Transformation executor and result
  26. passing field down the stream and populate in email
  27. Return only one part of .txt
  28. javascript compare all the columns
  29. Does the active transformation exist as Java object?
  30. Getting each file name as a field when reading several files in Microsoft Excel input
  31. Mail step with attachment name with "%" generates java exception
  32. Couldn't find field 'account_id' in row!
  33. Table Input DBLink
  34. Put files with secure FTP
  35. Job Properties - 'Job name' and 'Directory' greyed out
  36. Date "26.03.0218" is correct for PDI
  37. PDI 8.1 small error detected
  38. Pentaho CE 7.1 to 8.1 upgrade
  39. make the job database transactional
  40. Mapped network drive not available from within PDI (Win2012R2 server) [SOLVED]
  41. Memory error
  42. Microsoft Excel writer step does not recalculate formulas in excel
  43. Why does variable references include a space?
  44. How to pass parameter from PDi To PRD's PDI source?
  45. How to remove extra pipes in text sources
  46. java.net.SocketException: Connection reset error when trying to connect to Salesforce
  47. ERROR: Kitchen can't continue because the job couldn't be loaded
  48. Dynamic Update
  49. Hadoop shim ConfigurationException when running Kitchen
  50. SalesForceInput
  51. Pentaho Enterprise Version Comparisions
  52. Mail step Attached files not working
  53. Group By - What is best way to Concatenate strings separated by , - but UNIQUE vals?
  54. How to debug a set variable in spoon without error (parent job not available)
  55. Carte Explanation
  56. Hadoop Shim & User Home Issues
  57. Dimension lookup update
  58. sort anything that looks like a number in pentaho data integration using sort step
  59. Creating a .dat file. Header and body with distinct infraestructure.
  60. Data/Value breaking at comma (,) in csv
  61. How to clear result rows inside a transformation?
  62. Pentaho data integrator Secured Cluster Connetion
  63. Identify fields that are different after Merge Rows (Diff)
  64. Use of Separator in Text file Output step
  65. How to abort a job after downtime
  66. REST API - request token by sending certificate credentials
  67. Transform table to a structured table
  68. Put a field between "" automatically
  69. JSON Input - Array Values with same PATH name?
  70. Push transformation to carte via powershell
  71. How to access remote File Based Repository
  72. Unable to start blueprint container for bundle org.apache.karaf.features.core
  73. ElasticSearch Bulk Insert
  74. Decryt Data
  75. 8.1 CE - Problems with Text File Output Transformation, reverted back to 8.0
  76. 8.1: Call Mapping using parameters in Transformationpath
  77. Not able to execute ETL job from cmd prompt windows 10
  78. Java casting error after upgrading from PDI 6.1 to 7.1
  79. Handling tab seperated values and comma separated values in text file input
  80. How to read the last filename to notify it via email?
  81. Dummy step reporting failure
  82. occurences
  83. Couldn't get field info from [SELECT * FROM products LIMIT 0]
  84. Loop Advice Request
  85. Step fields and their origin
  86. Where does ${Internal.Entry.Current.Directory} actually point on a MAC?
  87. How to locate the correct installation instructions for PDI Community edition on MAC?
  88. libwebkitgtk is missing
  89. Reset field when "Group field" changes
  90. How to use the same output file as a stream lookup
  91. Creating piles of data
  92. DI Server is not triggring scheduled jobs on regular interval
  93. Java heap Space issue while reading large text file.
  94. JNDI configuration for Windows Authentication
  95. Linux without VNC viewer
  96. SQLite dynamic number typing causing issues
  97. Ubuntu Linux not able to see .kettle properties file
  98. Upload an excel file into google drive via PDI
  99. Need to log if a particular value is missing in excel file
  100. Connect to Google Bigquery with generic connection
  101. Linux batch file log error
  102. Every 5 rows of data - consolidate to 1 row?
  103. Question about string lookups in MS-SQL
  104. File/Open or Browse Repository not showing all files
  105. Issue with S3 File Output component in PDI 8.1 Solved
  106. Login token XXXX is invalid or has expired
  107. pentaho and elasticsearch
  108. attachments issue
  109. Cygwin with Pentaho
  110. How do I drop a link with an iloader call?
  111. Can't find bundle for base name org.pentaho.di.trans.steps.pentahoreporting.messages.
  112. How to upload kettle jobs and transformations in the Pentaho server?
  113. Detect modification in group of rows for snapshot table
  114. Special Characters
  115. Insert script generation in order
  116. When this bug correction take place?
  117. Dynamic Authorization Key for Rest Client
  118. Regex Evaluation capture group
  119. Need PDI 4.3 EE Installer
  120. UDJC causing hang in mapping transformation
  121. Excel input Step- Spread type engine
  122. Dynamic Input Normalization
  123. Unable to populate Oracle table with Oracle Bulk Loader
  124. Log missing feild in excel input file
  125. Copy results to parameters - Pentaho 8.1
  126. Carte - Job and Trans Image not rendering
  127. Log error if data is not in wrong format in excel file
  128. Kettle startup times in versions 7.0, 8.0 --- and 8.1 ?
  129. Split data from irregular CSV
  130. Salesforce Standard Integer Fields
  131. Call RT REST web service to retrieve ticket list
  132. Do we have some step to convert AD date into yyyy-MM-dd?
  133. Can you recommend some trick to create MySQL table to insert data from input?
  134. trying to avoid duplicate code in UDJC
  135. Any chance for working step "ElasticSearch Bulk Insert"?
  136. Select value metadata change gives wrong result.
  137. Multiple Kitchen log entries (console)
  138. Regex to retrieve part of string
  139. In what order are variables initialized?
  140. Log error if Sheet/Tab is missing in the input excel file
  141. PDI Development Environment
  142. Continue transformation flow even if Table Input has no rows
  143. Inserts on production enviroment concurrently
  144. Mysql Timeout
  145. Row_number Over inside a transformation
  146. Change default logging in spoon
  147. Cut in string at X characters but not inside words
  148. Mail Validator
  149. XML generation
  150. Problems with Timestamp with Time Zone
  151. Write sorted rows output into multiple excel files
  152. HMAC_SHA1 in Kettle
  153. EMAIL IMAP not connecting with tls 1.1 or 1.2
  154. Get file creation date
  155. Resetting Pentaho configurations
  156. Run Jar example
  157. Compiling Jar with dependencies
  158. Strange bug using "Copy rows to result" in sub-transformation
  159. Is there a difference between Kettle and PDIEE when running Jobs/Transformations?
  160. how to concatenate 100 output rows into one output row
  161. Pass result rows to transformation parameters fail
  162. pdi-ce- Step „Advanced http“ does not work. In pdi-ce- it works.
  163. How to obtain Timestamp in PDI?
  164. Filter 0 if there's row which have value more than 0
  165. pdi-ce- command pan.sh console java.awt.AWTError: Can't connect to X11
  166. create database repository for kettle pdi-ce- does not provide backend.
  167. Process the Column data in Excel File
  168. kettle pdi-ce- error on rename Excel Input Step in transformation
  169. Can I run Community Edition in a production environment?
  170. Join tables with a common where condition
  171. pdi-cd- / 8.2.x.x Excel Writer Step DATE TIMESTAMP Column null in Sheet
  172. pentaho-server community version with pentaho data integration
  173. mozi characters elimination using pdo
  174. Table input step with multiple statement
  175. PDI Data Science Notebook (Jupyter) Integration
  176. How to clear environmental variable?
  177. S3 file output not working in PDI 5.0.1 stable
  178. How to embed PDI in OSGI Bundle (Maven + Karaf Dependencies)
  179. how to add column with constant number to each file
  180. xml file Performance issue
  181. Modified Java Script Value - fireToDB - Database connection not found
  182. load binary data to table
  183. Calculation when the job runs in parallel threads
  184. Changes in License for PDI community edition after bought by Hitachi ?
  185. Executing bat file on remote machine from local machine in same network.
  186. Slow Load to Database
  187. How to find coresponding line in file?
  188. StAX Files processing - GC overhead limit exceeded
  189. HTTP post - proxy
  190. Step "Wait for file" with different File name
  191. Clarification on Pan and Kitchen
  192. PDI and Remote DB Connections
  193. Remote connection
  194. Get File Names - Empty Rows
  195. How do I connect PDI to read SSAS cubes? From Analysis Services.
  196. How to join constant columns from another step?
  197. Add variable or parameter to subjetc in a mail step
  198. Trigger a Table Input without the use of dummy parameters?
  199. SPARK AEL execution through Pan
  200. REST client keeps sending "Transfer-Encoding: chunked"
  201. [First init PDI8.2] [Linux] Creating configuration won't terminate
  202. DB Repository to File Repo
  203. differences between kettle and ?
  204. Unknown type 245 in column 0 of 1 in binary-encoded
  205. PDI (8.2) Status SVG file not found
  206. Launch Spoon on ubuntu 18.04
  207. Access of external jar using udjc step
  208. UDJC step throwing a compilation error
  209. PDI Microsoft Excel input step - Browse doesn't "see" xlsx files
  210. Rest API CDA for Report
  211. Find characters in a list
  212. Longest match
  213. Looking for efficient way to transfer a large table (Partitioning the input table?)
  214. Replace new line character(\n) in String using "Replace in String" step
  215. 8.2 CE Google Drive API how to see folders
  216. Scope of variables Different between kettle 5 and kettle 8
  217. Property Input not including subfolders
  218. Copy rows to result behavior
  219. Execute R Script - Access Denied to jri.dll
  220. BigQuery error with pentaho 8.2 using table output step
  221. Regarding Select Value step in kettle
  222. Kettle 8.2: Database lookup error with sqlserver
  223. Extracting data from a headings in a text file
  224. Records not getting populated correctly when no.of.copies > 1
  225. Convert degrees minutes seconds to decimal degrees
  226. Reading Transformation from GIT repository takes time than usual
  227. Spoon - Naming Split Files
  228. PDI 8.2 CE - How to create a database repository
  229. Database Connection Issues OUTPUT/ WRITING ONLY
  230. data to delete in multi level json string
  231. Dimension Look up update/ Vertica
  232. filtering XML data for a specific parent node
  233. Variable setting for Mail step works in Spoon, not in kitchen
  234. Sqlplus command not found
  235. Unexpected error during job metadata load
  236. Text file output -data not being written
  237. Help needed to Set PENTAHO_DI_JAVA_OPTIONS in UNIX
  238. Get data out of AWS SQS
  239. Pentaho 6.1 version not working
  240. Disabling a branch in a transformation
  241. Kettle 6.1 and XLSX File
  242. Remove value from multivalue LDAP attribute
  243. S3 CSV file input changes from PDI 6.1 to PDI 8.1
  244. Text File Output encoding ignored
  245. com.sybase.jdbc4.jdbc.SybDriver
  246. using date variable in dateDiff in javascript step
  247. Logging Best Practice and "Job ID"
  248. Read data from PDF file and need to load into table
  249. Problem with Merge Rows (diff) step
  250. Table input step problem when using substring function on Firebird 3.x