PDA

View Full Version : problema on el objeto e-mail de xaction



toni_apr
09-17-2012, 08:09 AM
Hola. Soy nuevo en el foro, y hay cosas que no controlo de la herramienta.

En esencia, estos días se configuraba el email_config.xml como se debe hacer. Como no daba conexión (daba siempre error, nunca se mandaba el mail), se modificó este config para que únicamente leyera "localhost", pero ni siquiera hace.."ping". Hoy además el objeto "e-mail" no lo reconoce el equipo (?)


He configurado en el servidor de pentaho el email-config.xml como he visto en internet. no me da conexión. he quitado todo, y puesto solo "localhost", pero es que el servidor de pentaho por el puerto 25 ni siquiera hace..."ping".

ademas, este componente de xaction de la noche a la mañana me da error y no se por que, ni siquiera me permite hacer un intento de envío. El config es (he cambiado datos personales)



<email-smtp>

<!-- The values within <properties> are passed directly to the JavaMail API.
For a list of valid properties see http://java.sun.com/products/javamail/javadocs/index.html -->
<properties>
<!-- This is the address of your SMTP email server for sending email. e.g. smtp.pentaho.org -->
<mail.smtp.host>aaa.bbb.es</mail.smtp.host>

<!-- This is the port of your SMTP email server. Usually this is 25. For GMail this is 587 -->
<mail.smtp.port>25</mail.smtp.port>

<!-- The transport for accessing the email server. Usually this is smtp. For GMail this is smtps -->
<mail.transport.protocol>smtp</mail.transport.protocol>

<!-- Usually this is 'false'. For GMail it is 'true' -->
<mail.smtp.starttls.enable>false</mail.smtp.starttls.enable>

<!-- Set to true if the email server requires the sender to authenticate -->
<mail.smtp.auth>false</mail.smtp.auth>

<!-- This is true if the email server requires an SSL connection. Usually 'false'. For GMail this is 'true' -->
<mail.smtp.ssl>false</mail.smtp.ssl>

<!-- Run Email Send Test -->
<mail.run.send.test>true</mail.run.send.test>

<!-- Output debug information from the JavaMail API -->
<mail.debug>false</mail.debug>

<!-- For GMail this is 'false' -->
<!--mail.smtp.quitwait>false</mail.smtp.quitwait-->

</properties>

<!-- The is the address of your POP3 email server for receiving email. e.g. pop.pentaho.org -->
<!-- It is currently not used -->
<mail.pop3></mail.pop3>

<!-- This is the default 'from' address that emails from the Pentaho BI Platform will appear to come from e.g. joe.pentaho@pentaho.org -->
<mail.from.default>pepe@empresa.com</mail.from.default>

<!-- This is the user id used to connect to the email server for sending email
It is only required if email-authenticate is set to true
This is never sent or shown to anyone -->
<mail.userid></mail.userid>

<!-- This is the password used to connect to the email server for sending email
It is only required if email-authenticate is set to true
This is never sent or shown to anyone -->
<mail.password></mail.password>

</email-smtp>


Y el XML generado por mi componente:

<?xml version="1.0" encoding="UTF-8"?>
<action-sequence>
<title>prueba_damian</title>
<version>1</version>
<logging-level>ERROR</logging-level>
<documentation>
<author/>
<description>Empty blank action sequence document</description>
<help/>
<result-type/>
<icon/>
</documentation>

<inputs/>

<outputs/>

<resources/>

<actions>
<action-definition>
<component-name>EmailComponent</component-name>
<action-type>E-Mail</action-type>
<component-definition>
<to><![CDATA[pepe@empresa.com]]></to>
<from><![CDATA[pepe@empresa.com]]></from>
<subject><![CDATA[hola]]></subject>
<message-plain><![CDATA[hola]]></message-plain>
</component-definition>
</action-definition>

</actions>
</action-sequence>


MUCHAS GRACIAS.