PDA

View Full Version : No X action in BIServer 5 ?



dzo
02-15-2013, 06:01 AM
Yesterday I downloaded a snapshot of BI Server 5, to try if some existing xaction reports would run.

I see the don't.

I have
- unzipped the biserver files and sftp'd them to my Linux server.
- set the scripts executable in the biserver-ce directory and the ../tomcat/bin directory
- started this biserver and logged in as joe
- imported the .xaction, .xml and .properties file (I see them all 3, opposite to biserver 4.5 wich I'm using now, where I only see the .xaction file)
- tried to run the .xaction
- got an errormessage on the ReportingSimpleComponent action, saying: ERROR [ExceptionLoggingDecorator] Reference number: 9bd889d7-cb98-4c05-814d-66c467178489
org.springframework.extensions.jcr.JcrSystemException: Repository access exception; nested exception is javax.jcr.RepositoryException: invalid identifier: /home/joe/Y_M_SRMC_DMC_Monthly_message_totals_per_message_state.xml

ERROR [SolutionEngine] 2eeabd23-7754-11e2-8b5f-005056ab3570:SOLUTION-ENGINE:/home/joe/Y_M_SRMC_DMC_Monthly_message_totals_per_message_state.xaction: Action Sequence execution failed, see details below
| Error Time: Friday, February 15, 2013 10:43:42 AM CET
| Session ID: joe
| Instance Id: 2eeabd23-7754-11e2-8b5f-005056ab3570
| Action Sequence: Y_M_SRMC_DMC_Monthly_message_totals_per_message_state.xaction
| Execution Stack:
EXECUTING ACTION: report (SimpleReportingComponent)
| Action Class: SimpleReportingComponent
| Action Desc: report
| Loop Index: 0
Stack Trace:org.pentaho.platform.api.engine.ActionExecutionException: RuntimeContext.ERROR_0017 - Activiteit kon niet worden uitgevoerd

Caused by: org.pentaho.platform.api.repository2.unified.UnifiedRepositoryException: exception while getting file with id "/home/joe/Y_M_SRMC_DMC_Monthly_message_totals_per_message_state.xml"


Is it supposed to work and am I doing something wrong?

Thanks,
Dzo