PDA

View Full Version : Sqoop import fails with Mapr



ayyappanm
07-27-2013, 09:16 PM
I have configured Kettle-Spoon 4.4 to use MAPR hadoop distribution. When I tried executing a Pentaho job with Sqoop import, I'm getting below error. Any help will really be helpful.

by buildguy) : Error running Sqoop
2013/07/27 19:32:28 - Sqoop Import - ERROR (version 4.4.0-stable, build 17588 from 2012-11-21 16.02.21 by buildguy) : java.lang.RuntimeException: java.lang.RuntimeException: java.io.IOException: Invalid prefix in maprfs://labmapr5:50030 expecting maprfs:///
2013/07/27 19:32:28 - Sqoop Import - ERROR (version 4.4.0-stable, build 17588 from 2012-11-21 16.02.21 by buildguy) : at org.apache.sqoop.Sqoop.runSqoop(Sqoop.java:186)
2013/07/27 19:32:28 - Sqoop Import - ERROR (version 4.4.0-stable, build 17588 from 2012-11-21 16.02.21 by buildguy) : at org.apache.sqoop.Sqoop.runTool(Sqoop.java:220)
2013/07/27 19:32:28 - Sqoop Import - ERROR (version 4.4.0-stable, build 17588 from 2012-11-21 16.02.21 by buildguy) : at com.cloudera.sqoop.Sqoop.runTool(Sqoop.java:49)
2013/07/27 19:32:28 - Sqoop Import - ERROR (version 4.4.0-stable, build 17588 from 2012-11-21 16.02.21 by buildguy) : at org.pentaho.hadoop.shim.common.CommonSqoopShim.runTool(CommonSqoopShim.java:44)
2013/07/27 19:32:28 - Sqoop Import - ERROR (version 4.4.0-stable, build 17588 from 2012-11-21 16.02.21 by buildguy) : at org.pentaho.di.job.entries.sqoop.AbstractSqoopJobEntry.executeSqoop(AbstractSqoopJobEntry.java:259)
2013/07/27 19:32:28 - Sqoop Import - ERROR (version 4.4.0-stable, build 17588 from 2012-11-21 16.02.21 by buildguy) : at org.pentaho.di.job.entries.sqoop.AbstractSqoopJobEntry$1.run(AbstractSqoopJobEntry.java:231)
2013/07/27 19:32:28 - Sqoop Import - ERROR (version 4.4.0-stable, build 17588 from 2012-11-21 16.02.21 by buildguy) : at java.lang.Thread.run(Thread.java:662)
2013/07/27 19:32:28 - Sqoop Import - ERROR (version 4.4.0-stable, build 17588 from 2012-11-21 16.02.21 by buildguy) : Caused by: java.lang.RuntimeException: java.io.IOException: Invalid prefix in maprfs://labmapr5:50030 expecting maprfs:///


11465

ayyappanm
07-30-2013, 09:26 AM
HI,

I believe the link provides details/parameters for Sqoop through CLI.

My error occurs when providing namenode/jobtracker node in Sqoop pluging in Kettle - Spoon.

mattb_pdi
08-02-2013, 09:55 PM
I believe the MapR client is already configured to link MAPRFS to your labmapr:50030 node, correct? If so, try leaving the Jobtracker information for Host and Port blank, that might work.

ayyappanm
08-05-2013, 03:16 PM
Thanks a lot! On leaving the jobtracker information blank, Sqoop started working fine. :)