PDA

View Full Version : Kettle behind Proxy using Google Analytics



jurban
03-17-2014, 12:24 PM
I've got the CE version of Kettle deployed on Windows on a VMWare instance behind a proxy. The Google Analytics module does not authenticate. I've verified that an equivalent stack on Amazon WS does function with the same credentials. The only difference I can determine between the two systems is that the VM is behind the proxy.

I have no ability to adjust the proxy.
I've adjusted the OS environments (with a re-boot) to point towards the proxy.
I've added a few lines in the Spoon.bat file to point towards the proxy.
I've adjusted the java console to point towards the proxy.

The same error message appears (something like "Check your credentials", which is the message coded into the module code - I checked that too).

I have succeeded in getting a perl script to draw down a report in XML format. But, I'd rather not have to parse every XML report output I generate (I've got a lot to do as well as manage on an ongoing basis, so this doesn't scale easily). So, I seem to be able to get an auth request through the proxy via a cygwin+perl executing a CURL command, but not via the GA module: (http://forums.pentaho.com/showthread.php?155802-Google-Analytics-Core-API-2-4-access-via-http-client)

First, does anyone have any suggestions on troubleshooting this issue? The log file response on the module doesn't provide sufficient evidence that the message is getting out to the Google API. So, I can't seem to determine if the issue is outbound or inbound. I've also opened the API to All domains, so that shouldn't be a constraint.

Any insights would be very helpful as I've been working on this for a week with no success.

Thanks,
-Joe Urban

jurban
03-24-2014, 04:31 PM
Update: I've had IT disable the proxy and re-tested the GA module. Authentication failed just as before. So, the issue is probably not the proxy.

I just installed Kettle 5.0.1 to see if that impacted the module's performance. Authentication failed again.

I'm using a VM. Is it possible that the module is impacted by the VM environment?

--Joe

teshvora
10-16-2014, 08:52 AM
Hello Everyone,

Did anyone get a resolution to this problem? I'm trying to use the Google Analytics step (Pentaho DI 5.0.1-stable) and am seeing Authentication problems. I've worked my through the Wiki page (See link below), and still no luck retrieving imformation. I get the error message:

"Authentication failure occured when contacting Google Analytics. Please verify the credentials in the email and password fields as well as your network connectivity."

If anyone has resolved this problem, or has any advice running the Google Analytics module, I would be most grateful.


http://wiki.pentaho.com/display/EAI/Google+Analytics

Prerequisites



You must have a Google Analytics account.
The Google Analytics API requires an API key. Here is how to get it:

Navigate to http://console.developers.google.com (http://console.developers.google.com/) and click on API Console under Developer Tools.
Sign in with your credentials.
From the Projects page, create a new project. Once created, click 'Enable an API'. Locate the 'Analytics API', and click the 'OFF' button to change the value to 'ON'. turn on Analytics API.
Click on the 'Credentials' link in the left-hand menu, and create a new Server Key for 'Public API access'. Enter in your IP address or network, or enter '0.0.0.0/0' to allow global access (not recommended for production systems). Once created, an API Key will be displayed. This is the key that is to be entered in the field within the Google Analytics step.

teshvora
10-17-2014, 06:31 AM
Security Setting found to enable PDI to access Google Analytics ...

One thing you need to do to allow Google Analytics to work with PDI is to enable Access for less secure apps ...

This setting can be found in Google Account Security settings. Click on your account id (Go to google home page, top right hand corner you should see your id if your signed in - sign-in of not). When you select your ID you'll have options for 'Account', 'Privacy' and 'View Profile'. Select Account, and then from the Security menu, you'll see the option for Access for less secure apps ... make sure this is enable.

Still trying to figure out how to get around our Firewall & Proxy ...

teshvora
10-21-2014, 12:04 PM
I have been experiementing with adding some Java options in spoon.bat ... The options are:

-DproxySet=true
-Dhttp.proxyHost=
-Dhttp.proxyPort=
-Dhttp.proxyUser=
-Dhttp.proxyPassword=

I plugged these values into the command that starts kettle in spoon.bat

%SPOON_START_OPTION% "%_PENTAHO_JAVA%" "-DproxySet=true" "-Dhttp.proxyHost=xxx" "-Dhttp.proxyPort=xxx" "-Dhttp.proxyUser=xxx" "-Dhttp.proxyPassword=xxx" %OPT% -jar launcher\pentaho-application-launcher-5.0.1-stable.jar -lib ..\%LIBSPATH% %_cmdline%

This did not work for me, but let me know if it works for you.

teshvora
10-22-2014, 04:05 AM
I have it on good authority that using the Google Analytics step via a proxy is not possible (at this point in time). Someone may pay for development and update the Google Analytics module in the future, but for now you need to bypass the proxy and punch a hole in the firewall.

napo
09-06-2017, 03:41 AM
It works well after adding https proxy in spoon.bat file. Only http proxy will not work.