PDA

View Full Version : エラーが出ているのに、ログにエラーメッセージが何も出なくなりました



aneja
10-18-2014, 09:48 PM
みなさま、こんにちは。

windows7 64bitOSマシンにpentaho BIサーバ CE 5.0.1 stableバージョンを新規インストールし、
その後で、データベースをPostgresql9.2に変更しようとしています。

インストールディレクトリに入っていた説明書やこちらのフォーラムなどを参考にしながら、
一つずつエラーを潰していたのですが、あるエラーに対処した後再起動すると、
web上で「HTTP Status 404」のエラーが出ました。
ですが、ログに何もエラーメッセージが出ていません。

start-pentaho-debug.batで起動しても、状況は変わりません。
catalina.2014-10-19.logの中身は以下の通りで、他のログファイルには何も書かれていません。

------------------------------------------------
10 19, 2014 1:49:34 午後 org.apache.catalina.core.AprLifecycleListener init
INFO: The APR based Apache Tomcat Native library which allows optimal performance in production environments was not found on the java.library.path: C:\Program Files\Java\jre7\bin;(投稿者注:以降省略)
10 19, 2014 1:49:34 午後 org.apache.coyote.http11.Http11Protocol init
INFO: Initializing Coyote HTTP/1.1 on http-8080
10 19, 2014 1:49:34 午後 org.apache.catalina.startup.Catalina load
INFO: Initialization processed in 663 ms
10 19, 2014 1:49:34 午後 org.apache.catalina.core.StandardService start
INFO: Starting service Catalina
10 19, 2014 1:49:34 午後 org.apache.catalina.core.StandardEngine start
INFO: Starting Servlet Engine: Apache Tomcat/6.0.36
10 19, 2014 1:49:34 午後 org.apache.catalina.startup.HostConfig deployDirectory
INFO: Deploying web application directory pentaho
10 19, 2014 1:49:36 午後 org.apache.catalina.startup.HostConfig deployDirectory
INFO: Deploying web application directory pentaho-style
10 19, 2014 1:49:36 午後 org.apache.catalina.startup.HostConfig deployDirectory
INFO: Deploying web application directory ROOT
10 19, 2014 1:49:36 午後 org.apache.catalina.startup.HostConfig deployDirectory
INFO: Deploying web application directory sw-style
10 19, 2014 1:49:36 午後 org.apache.coyote.http11.Http11Protocol start
INFO: Starting Coyote HTTP/1.1 on http-8080
10 19, 2014 1:49:36 午後 org.apache.jk.common.ChannelSocket init
INFO: JK: ajp13 listening on /0.0.0.0:8009
10 19, 2014 1:49:36 午後 org.apache.jk.server.JkMain start
INFO: Jk running ID=0 time=0/30 config=null
10 19, 2014 1:49:36 午後 org.apache.catalina.startup.Catalina start
INFO: Server startup in 1570 ms
------------------------------------------------

これだと正常に起動しているように見えて、トラブルシューティングしように無く、困っています。
この現象のきっかけは、

pentaho\biserver-ce\tomcat\webapps\pentaho\META-INF\context.xml

を1部変更したことによりますが、変更箇所を元に戻して再起動してみても、エラーがずらずら出ていた
以前の状態に戻りませんでした。つまり、再現しなくなりました。

ちなみに、

http://www.patlaf.com/quick-tips-to-troubleshoot-the-first-installation-of-pentaho-bi-5-0-1-ce-with-mysql/

の投稿に従って、context.xml を変更した時は、以下のファイル/ディレクトリを消すようにしています。

tomcat/logs/*
tomcat/conf/Catalina/localhost/pentaho.xml
tomcat/temp/*
tomcat/work/Catalina
pentaho-solutions/system/jackrabbit/repository

元のように、ログにエラーメッセージが出るようにするには、どのようにすればよいでしょうか。
最悪、再インストールするしかないのでしょうか。
何か思い当たる点などありましたら、情報共有をぜひともお願いいたします。