PDA

View Full Version : Problems Deploying pentaho.war in Jboss 4.0.2



mikepre
09-08-2005, 01:18 PM
First, congratulations for your effort in providing the market with this set of valuable tools.

I installed the preconfigured package and everything run OK.

Now, I unistalled Jakarta Tomcat and installed Jboss 4.0.2 as per your recommendations.

I had a problem deploying pentaho.war no matter I followed the instructions (I probably missed something).

I enclose error log captured after starting Jboss App Server having previously deployed the .war file.

I would appreciate any advice on it.

Best regards

Michael Prendergast
http://forums.pentaho.org/archived_att/files/error_log.txt

jdixon
09-08-2005, 01:57 PM
Hi Mike,

it looks like the WAR is deployed ok, but it cannot find the 'pentaho-solutions' folder.

Instructions for doing this is in the lastest Advanced Install Guide on page 4

James Dixon

mikepre
09-08-2005, 02:00 PM
Thank you for your fast reply...

I'll double check everything and let you know.

I'll put hard and long hours testing it, since the hole platform captured my attention.

Keep on going,

Michael

mikepre
09-08-2005, 02:48 PM
In order to avoid the guessing game, can you specify the exact loaction of the pentaho_solutions-0.9.7.2 directory in the App Server (Jboss) ?

I have tried at least 3 times with no luck

Thank you,

Michael

gmoran
09-09-2005, 08:53 AM
Hi Michael,

Here's how the platform finds the solutions directory today:

If you don't tell the platform anything (no configuration), then on startup, the platform engine will search from the directory that the .war is deployed in, up to the root of the application server home, looking for a sibling directory named "pentaho-solutions". Once the engine finds this directory it assumes that it is the root directory of your solutions.

Before you force a solutions path on your platform engine (I'll explain this is a sec), you can check a few things to see why the original search is failing:

First, the engine is lookiing specifically for the name "pentaho-solutions" - is that the name of your solutions directory? This is important, the directory name cannot have the version number appended to it.

Second, does your solutions directory live as a sibling to the root of your app server installation? For example, if your app server is installed to d:/apps/jboss4.0.2, then the pentaho-solutions directory should be located at d:/apps/pentaho-solutions. (I'm assuming the Windows platform here - if you're a UNIX guy, forgive me and translate the example).

And last, you must be certain that the pentaho-solutions directory is really the root directory of your solutions. You can tell it is the root if it has a child directory named system. If not, then you have too many layers in your directories - you will need to pare down the directory tree until system is a child of the directory pentaho-solutions. For a more detailed example of the way the solutions tree is structured, check out our Advanced Install Guide.

If, after checking the guidelines listed above, the platform still doesn't find the solutions directory, you can force the engine to look for the directory by specifying an absolute path to it:


Extract the web.xml file (from the .war)
Find the element that has the value ‘solution-path’.
Directly after the element, enter a element, and set its value to the absolute path to the ‘pentaho-solutions’ directory.

Example:


solution-path
d:\\pentaho\\pentaho-solutions
Rebuild the .war file.
Re-deploy the .war you just rebuilt.

Hope this helps, let me know if you are still having problems or if this resolved the issue for you.

Best Regards,
Gretchen

Post edited by: gmoran, at: 09/14/2005 10:20[url]

Post edited by: gmoran, at: 09/14/2005 10:23

Post edited by: gmoran, at: 09/14/2005 10:24

Post edited by: gmoran, at: 09/14/2005 10:34

Post edited by: gmoran, at: 09/14/2005 10:35

mikepre
09-09-2005, 05:21 PM
we're getting closer. I guess now it's deployed (the problem was the pentaho-solutions directory having trailing characaters for the version, which was corrected) , but nothing happens when connecting to

http://mymachine:8080/pentaho/jsp/Navigate.jsp

I captured the run.bat messages and found what I guess a problem with my IP address, maybe due to the fact I'm running the application on a notebook with a wireless card and a LAN card (yeah, a Win XP machine :)

look at:

20:03:47,734 INFO [Http11Protocol] Initializing Coyote HTTP/1.1 on http-0.0.0.0-8080

and then I get a:

20:04:22,453 INFO [WebappClassLoader] validateJarFile(C:\\pentaho\\jboss-4.0.2\\server\\default\\.\\tmp\\deploy\\tmp33869pentaho-exp.war\\WEB-INF\\lib\\servlet-api.jar) - jar not loaded. See Servlet Spec 2.3, section 9.7.2. Offending class: javax/servlet/Servlet.class

Am I right?

If so, what should I do?

I enclose captured messages.

Regards,

Michael

mikepre
09-09-2005, 05:22 PM
here's the file http://forums.pentaho.org/archived_att/files/capture.txt

gmoran
09-14-2005, 12:01 PM
Hey Mike,

Sorry its taken so long to get back to you - the problem you are seeing is because the war that you are deploying contains ALL the jars needed to build and run the platform. All of these jars are not necessary in JBoss, because JBoss has its own version of some of them that it prefers to use. Unfortunately, some of them actually cause JBoss to not deploy your war, but because the war is packaged as generically as possible we don't just exclude these jars.

So the solution is for you to open up the war, delete the necessary jars, repackage the war file and redeploy it. The list of jars that COULD cause trouble are:

activation.jar
concurrent.jar
dom4j-1.5.2.jar
hsqldb.jar
jaxen.jar
mail.jar
saaj.jar
jaxrpc.jar
xercesImpl.jar
xml-apis.jar
cglib-2.1.jar
commons-httpclient-2.0.2.jar
commons-logging.jar
log4j-1.2.8.jar
jsp-api.jar
servlet-api.jar
asm.jar
asm-attrs.jar
ehcache-1.1.jar
hibernate3.jar
jta.jar
foEmitter.jar
htmlEmitter.jar
portlet-api-1.0.jar
The jars that are most likely the root of your problem are servlet-api.jar and jsp-api.jar. I would recommend removing atleast those two, redeploying and seeing if you experience any other troubles. Let me know how it goes for you!

Best Regards,
Gretchen

mikepre
09-14-2005, 12:13 PM
Shouldn't it be more "clean" to deploy that .WAR in Jakarta Tomcat for example?

Michael

gmoran
09-14-2005, 01:21 PM
Mike,

As with most software projects, "clean" is coming with time and revisions of our build process and code. :)

We intend to make some changes so that the .war distribution that we have on sourceforge doesn't need to be messed with under a simple vanilla tomcat deployment. However, JBoss, WebSphere and other application servers differ in their class loading schemes enough that we cannot begin to try to guess the possible scenarios under which a classloading problem might occur. This early in development, we are relying on our community to let us know what issues they might have deploying the binaries we have released, so we can provide broader troubleshooting knowledge and of course, make our deployment "cleaner".

If you're not comfortable following the steps for modifying the .war file as I mentioned in my previous post, another alternative for you is to copy the pentaho.war directory out of our pre-configured installation, and drop it into your JBoss application server. The pentaho.war directory is configured specifically for JBoss 4.0.2 with the JBoss Portal, so you should have no trouble deploying it, as long as you don't have other applications deployed that could interfere with the platform.

The steps to follow are:

Download the preconfigured installation from sourceforge.net. Explode the zip file Stop your JBoss server. Copy the /server/default/deploy/pentaho.war to your JBoss deploy directory. Start your JBoss server.

Also check out the following post regarding a warning about troubleshooting a JBoss 4.0.2 deployment -
http://forums.pentaho.org/showthread.php?t=25725

Hope this helps,
Gretch

mikepre
09-15-2005, 06:53 AM
:laugh:

Removing servlet-api.jar and jsp-api.jar did the thing.

Now, I'll try to set up my own solution and let you know. I'm specially interested in Mondrian/Jpivot support and MS SQL Analysis Services integration (through MDX, can I do so?).

Have a nice day

Michael

gmoran
09-15-2005, 07:44 AM
Michael,

I'm glad things are up and running for you - our conversations will contribute to improving the distributions we're creating, and hopefully help the next guy deploy:)

Mondrian and JPivot support as well as MSAS are slated as upcoming features, we just need to flesh out where they will fall on the timeline - we are constantly updating our roadmap, so keep checking back, you should see the features you are interested in there soon!

Best Regards,
Gretchen