PDA

View Full Version : JPivot Error



bhagan
11-29-2005, 09:19 AM
Hello,

I've installed the demo on two windows machines (one xp and one 2000 pro). They both worked initially. Now, whenever I attempt to launch the demo, I receive a JPivot error page.

Maybe I have caused a problem when I
- Clicked the stop-pentaho.bat file, the sever console remains and I had to manually close the command window.
- I modifed {PCI}/jboss/server/default/deploy, {PCI}/jboss/server/default/deploy/pentaho.war/WEB-INF/web.xml, and {PCI}/jboss/server/default/deploy/pentaho.war/WEB-INF/jboss-web.xml so I could use JNDI to identify the report database (following the Creating Solutions Guide.) However, I only did this on one machine, so I don't how this could cause the problem on both boxes.

I've attached the stack trace. http://forums.pentaho.org/archived_att/files/jpivotError.txt

jdixon
11-29-2005, 10:47 AM
from the stack trace it looks like one of your action sequence documents is missing a required element. The required elements are

* action-sequence/title
* action-sequence/documentation/description
* action-sequence/documentation/author

We will make it so that these are optional

James

bhagan
11-29-2005, 11:40 AM
I checked my action sequences, and they do not have the elements that you mentioned. I also ran the pentaho samples by typing the urls into the address bar, and this worked, so I don't think it is the samples. I am getting the error I described when I start the server and type http://localhost:8080/ or when I try to access http://localhost:8080/pentaho/jsp/Navigate.jsp etc.

Also, the CreatingPentahoSolutions_0.9.8.1 on page 31 does not list the elements as required.

Thanks for the quick response.

jdixon
11-29-2005, 01:59 PM
Does your log file show lines like this before the error occurs?

16:54:29,750 INFO [SolutionRepository] SOLUTION-REPOSITORY:: Adding action to solution repository quadrant-budget-emailed.xaction

What is the few lines before the stack trace starts?

A valid action sequence starts off like this:

<action-sequence>
<name>BIRT-quadrant-budget-for-region-hsql.xaction</name>
<version>1</version>
<title>%title</title>
<logging-level>debug</logging-level>
<documentation>
<author>James Dixon</author>
<description>%description</description>
<icon>BIRT-quadrant-budget-for-region-hsql.png</icon>
<help></help>
<result-type>report</result-type>
</documentation>

The documentation does not list these elements as required, but they are required by the version of the solution repository that you are running.

James

bhagan
11-29-2005, 02:38 PM
I saw no lines with the INFO label, except for "INFO [STDOUT] Pentaho BI Platform server is ready." As I recall, the log has the normal server startup output. Then immediately after is the error that I encountered.

These are a few lines up to the start of the exception:

2005-11-29 12:16:44,095 DEBUG [Locking] [B@18ef117 releasing lock for /schemes.def.xml at 1133284604095
2005-11-29 12:16:47,751 WARN [org.hibernate.impl.SessionFactoryObjectFactory] InitialContext did not implement EventContext
2005-11-29 12:16:55,798 DEBUG [org.pentaho.logging.Logger] misc-org.pentaho.system.PentahoSystem: ISolutionEngine class name is org.pentaho.solution.SolutionEngine with scope of global
2005-11-29 12:16:55,845 DEBUG [org.pentaho.logging.Logger] misc-org.pentaho.system.PentahoSystem: ISolutionRepositoryClass class name is org.pentaho.repository.filebased.solution.SolutionRepository with scope of session
2005-11-29 12:16:55,860 DEBUG [org.pentaho.logging.Logger] misc-org.pentaho.system.PentahoSystem: IRuntimeRepository class name is org.pentaho.repository.runtime.RuntimeRepository with scope of session
2005-11-29 12:16:55,860 DEBUG [org.pentaho.logging.Logger] misc-org.pentaho.system.PentahoSystem: IContentRepository class name is org.pentaho.repository.content.ContentRepository with scope of session
2005-11-29 12:16:56,423 DEBUG [org.pentaho.logging.Logger] misc-org.pentaho.scheduler.QuartzSystemListener: PentahoQuartzScheduler
2005-11-29 12:16:56,470 INFO [STDOUT] Pentaho BI Platform server is ready.
2005-11-29 12:17:07,501 DEBUG [org.pentaho.logging.Logger] misc-org.pentaho.session.PentahoHttpSessionListener: Session 7EE37E21AD27390DC7CA8431C76964F7 created
2005-11-29 12:17:09,563 ERROR [com.tonbeller.wcf.controller.RequestFilter]
java.lang.IllegalArgumentException: Adding text to an XML document must not be null

- bhagan

jdixon
11-30-2005, 10:33 AM
If you action sequences do not have the required elements mentioned below, then you will get the repository exception that you are seeing. Make sure you have all of those elements in every action sequence.

The next release tomorrow, will not have this requirement.

James