PDA

View Full Version : Pentaho 1.0.0 RC1 on Tomcat 5 + Apache 2 Issues



MVoort
12-02-2005, 02:03 AM
I am trying to install Pentaho 1.0.0 RC1 on Tomcat 5.5.12 + Apache 2.0.55. To do this I have done the following:

Downloaded pentaho_j2ee_deployments-1.0.0.RC1.zip
Downloaded pentaho_data-1.0.0.RC1
Downloaded pentaho_solutions-1.0.0.RC1
Installed JDK 1.5.0.06
Installed Ant 1.6.5

I unpacked the pentaho_data-1.0.0.RC1.zip file in C:\\pentaho directory and when I double clicked the start_hypersonic.bat the console window gave the following error:

C:\\pentaho\\pentaho-data>java -cp lib\\hsqldb.jar org.hsqldb.Server -database.0 sampledata\\sampledata
-dbname.0 sampledata -database.1 shark\\shark -dbname.1 shark -database.2 hibernate\\hibernate -dbname
.2 hibernate -database.3 quartz\\quartz -dbname.3 quartz
[Server@712c4e]: [Thread[main,5,main]]: checkRunning(false) entered
[Server@712c4e]: [Thread[main,5,main]]: checkRunning(false) exited
[Server@712c4e]: Startup sequence initiated from main() method
[Server@712c4e]: Loaded properties from [C:\\pentaho\\pentaho-data\\server.properties]
[Server@712c4e]: Initiating startup sequence...
[Server@712c4e]: Server socket opened successfully in 261 ms.
java.lang.NoClassDefFoundError
at org.hsqldb.persist.Logger.closeLog(Unknown Source)
at org.hsqldb.Database.reopen(Unknown Source)
at org.hsqldb.Database.open(Unknown Source)
at org.hsqldb.DatabaseManager.getDatabase(Unknown Source)
at org.hsqldb.DatabaseManager.getDatabase(Unknown Source)
at org.hsqldb.Server.openDatabases(Unknown Source)
at org.hsqldb.Server.run(Unknown Source)
at org.hsqldb.Server.access$000(Unknown Source)
at org.hsqldb.Server$ServerThread.run(Unknown Source)

This leaves me with some confusion, I know that something is not correct in my PATH setting but what is wrong I do not know.

I continued with the installation of the other elements by unpacking the pentaho_solutions-1.0.0.RC1.zip in C:\\Apache Software Foundation\\Tomcat 5.5 directory.

The last step I performed was building a tomcat5.0.war file from the pentaho_j2ee_deployments-1.0.0.RC1.zip with Ant. The .war file was created successfully.

I deployed the .war file into the \\htdocs\\pentaho directory of Apache as I configured Tomcat to use the Apache DocumentRoot instead of it's own by adding the following to the server.xml file:

Host name="localhost" appBase="C:/Apache Group/Apache2" unpackWARs="true" autoDeploy="true" xmlValidation="false" xmlNamespaceAware="false"
Context path="" docBase="htdocs" reloadable="true"

And I added the following entry to workers2.properties file in the Apache Group\\Apache2\\conf:

[uri:/pentaho/*]
worker=ajp13:localhost:8009

I copied the hsqldb.jar to the endorsed library directory in Tomcat and I added the described datasource definitions (without any modification) in the server.xml file.

I verified that Tomcat and Apache both are working correctly but when I try to open the http://localhost:8800/pentaho/ I get a directory listing.

To make a long story short what did I do wrong? Any help is appreciated.

Many thanks in advance!

Post edited by: MVoort, at: 12/02/2005 06:19

Post edited by: MVoort, at: 12/02/2005 10:09

gmoran
12-02-2005, 07:41 AM
Hey there,

I have successfully run the Hypersonic databases using JDK 1.5.0_06 from the RC1 build. I haven't seen this error before, but there are a few things we can try -


First, open the start_hypersonic.bat file, and before any other commands are executed, add the following lines to the script:


setlocal
set CLASSPATH=

This will clear your classpath for the duration of the script execution, so that we can rule out the possibility of any jars on your classpath causing a conflict.


If my first suggestion doesn't work, can you look in your log files and see if there is more information on the exception you are getting? Post any additional errors you might find from the logs, that might clue us in better as to what is happening.



The other problem is that the URL you are trying to access won't get you to the Pentaho application because we do not have a welcome-file in the root of the web-app for Tomcat (definitely will resolve that for our GA release, thanks!). So the URL you should be trying is http://localhost:8080/pentaho/jsp/Navigate.jsp, or http://localhost:8080/pentaho/Navigate. NOTE that hitting this URL is not going to go well until we resolve the issue with the databases though.

regards,
Gretchen

MVoort
12-05-2005, 01:47 AM
Hi,

Thanks for your quick reply.

I have added the 2 lines you mentioned in the start_hypersonic.bat file, and tried to start the hypersonic database. This gave me the same error as before. I checked my PATH
C:\\Program Files\\Java\\jdk1.5.0_06\\bin (system variable) and JAVA_HOME
C:\\Program Files\\Java\\jdk1.5.0_06 (user variable).

Unfortunatly I can not find an error log related to the hypersonic database.

Marcel

gmoran
12-05-2005, 10:52 AM
Hey Marcel,

I am puzzled as well by the errors you are seeing, because Hypersonic is a fairly isolated engine that only relies on its own jar file (plus jre of course) to start up.

Can you tell me where you got your pentaho-data files? Did you download them from the RC1 release on sourceforge.net? Did you replace or modify the hsqldb.jar in the lib directory?

You may want to try downloading the pentaho-data_1.0.0.RC1.zip file from sourceforge, just in case the files were not complete the first time.

Also check in the individual subdirectories (while the engine is stopped) for any .lck or .log files, and delete any that you find. They could exist in the sampledata, hypersonic shark or quartz directories.

Gretch