PDA

View Full Version : Language support ?



ingo.klose
12-21-2005, 12:52 PM
Hello,

I have a question regarding an internationalization issue. I just installed the Pentaho demo application on a German windows system. I would like to set English as the standard language since the German translation is not finished, yet. Is there a way to force the application to use English?

I also tried to change the language setting of my browser to English. Still all descriptors would come up with [de_xyz]. I assume that means that the web application pulls the german property files. Is that a bug or am I doing something wrong?

Thanks a lot in advance.

Best regards,
Ingo

jdixon
12-21-2005, 09:10 PM
Changing the browser language setting to English should be enough. This is how we test the translations.

1) Try setting the default locale and country in jboss/server/default/deploy/pentaho.war/WEB-INF/web.xml
e.g.
&nbsp;&nbsp;<context-param>
&nbsp;&nbsp;&nbsp;&nbsp;<param-name>locale-language</param-name>
&nbsp;&nbsp;&nbsp;&nbsp;<param-value>en</param-value>
&nbsp;&nbsp;</context-param>
&nbsp;&nbsp;<context-param>
&nbsp;&nbsp;&nbsp;&nbsp;<param-name>locale-country</param-name>
&nbsp;&nbsp;&nbsp;&nbsp;<param-value>US</param-value>
&nbsp;&nbsp;</context-param>


2) If this does not work try changing the name of jboss/server/default/deploy/pentaho.war/WEB-INF/classes/org/pentaho/ui/message.properties to messages_en.properties and see if some of the messages switch back to English. If this works you will need to rename all of the messages.properties files to messages_en.properties.

3) If this does not work take a backup of pentaho.war and delete all of the messages_de.properties files.

Please let us know which of these work best for you.

James

ingo.klose
01-02-2006, 12:15 PM
Hi James,

thanks for your help. I finally had to remove all *_de.properties files not only in pentaho.war but also in the demo folder.

Now the system is running in English.

Bye,
Ingo

espel
05-31-2006, 06:05 AM
Hello:
I have the same problem with spanish language. What do you mean with demo directory ? do i have to delete every message_es.properties in pentaho-demo ?
Thanks !

ingo.klose
05-31-2006, 06:37 AM
Hello espel,

that is exactly what I did. If the system is looking for the *_es.properties files and does not find any, it will use the default files, which are the english ones.

Therefore after removing all *_es.properties files from the Pentaho folders, the english version is displayed by default.

I know there should be a better way to handle this problem, such as setting the language in the browser etc. but, at least in the former releases, that would not work and I had to use this sledge hammer method instead.

Hope that helps.

Best regards,
Ingo

espel
05-31-2006, 07:13 AM
hello ingo.klose:

It did solve my problem.
Thanks !

Post edited by: alsdj, at: 05/31/2006 12:25

ingo.klose
05-31-2006, 08:01 AM
Hello,

did you re-publish the Pentaho solutions or restart the demo application?

From the Pentaho Internationalization Guide:

The names and descriptions of Action documents are cached and must be published. To publish,
navigate to the top level of the Pentaho BI Components Demo. The default URL is http://localhost:8080/pentaho. Click
on “Settings and Services??? and then select “Update Settings and Content???. Click on the “Publish??? link for the
“Solution Repository??? publisher. It is helpful if you keep this page available while translating.

After publishing the englisch names and descriptions should be visible.

By the way the complete Pentaho Internationalization Guide can be found in the download area.

Good luck,
Ingo