PDA

View Full Version : Getting to AdminCMS Portlet



freshasp
12-30-2005, 09:32 AM
Hi,

I am trying to get to the AdminCMS portlet as documented in the JBoss Portal 2.0 manual (running the Pentaho 1.0 out-of-the-box demo environment).

I login as the admin user (admin/admin) without problem but the portlet does not appear. Neither does it appear when I go to the URL listed on p.15 of the Portal 2.0 User Guide. Has it been disabled? Any ideas how I can get it back?

What are Pentaho's plans for moving to JBoss Portal 2.2?

Many thanks,
Paul

jdixon
01-04-2006, 06:44 AM
Hi Paul,

For the purposes of our demo we have disabled the Portal Admin page.

You can get it back by editing the default portal.

1. Go to pentaho-demo/jboss/server/default/deploy/jboss-portal.sar/portal-core.war/WEB-INF

2. Edit default-portal.xml

3. You will see (on line 36 and line 56) that the Portal Admin page is commented out.

4. Change line 36 from <!-- page> to <page>

5. Change line 56 from </page --> to </page>

6. Start the demo server

We are looking into moving to Jboss Portal 2.2

James Dixon

freshasp
01-10-2006, 10:49 AM
Thanks James - this gets me the Portal Admin page, but I can't seem to find the AdminCMS portlet. Am I missing something or does this need a further config change?

Paul

jdixon
01-23-2006, 09:30 AM
You need to add portlets to get the CMS stuff to work. If you have an original JBoss Portal 2.0 installation these portlets are defined in

jboss-4.0.1sp1/server/default/deploy/portal-core.sar/portal-core.war/WEB-INF/portlet.xml
jboss-4.0.1sp1/server/default/deploy/portal-core.sar/portal-core.war/WEB-INF/jboss-portlet.xml
jboss-4.0.1sp1/server/default/deploy/portal-core.sar/portal-core.war/WEB-INF/portlet-instances.xml
jboss-4.0.1sp1/server/default/deploy/portal-core.sar/portal-core.war/WEB-INF/default-portal.xml

James

dogchile
11-21-2006, 08:20 PM
Hello James,
I have pentaho-1.2.0.470-RC3 PCI, and I have not the default-portal.xml file. Where can I find that? thanks in advance..

PD: Sorry my english..