PDA

View Full Version : Having trouble with JDBC driver



agus.prayudhi
01-11-2006, 01:44 AM
I got another error in JDBC besides http://forums.pentaho.org/showthread.php?t=25786.

There are some typos in my previous post:
I did all the steps in Advanced Install Guide (for tomcat5):
- extract pentaho-solutions to tomcat-home\\webapps
- successfully run hypersonic database
- copy hsqldb.jar to tomcat-home\\common\\endorsed
- put pentaho.war (I created using ant 1.6.5) to tomcat-home\\webapps
- add jndi datasource mappings to tomcat-home\\conf\\server.xml


This exception is generated when I am trying to access http://localhost:8080/pentaho/UpdateSampleEmails (bursting examples):

javax.servlet.ServletException: Cannot create JDBC driver of class '' for connect URL 'null'
org.apache.jasper.runtime.PageContextImpl.doHandlePageException(PageContextImpl.java:848)
org.apache.jasper.runtime.PageContextImpl.handlePageException(PageContextImpl.java:781)
org.apache.jsp.jsp.UpdateSampleEmails_jsp._jspService(org.apache.jsp.jsp.UpdateSampleEmails_jsp:363)
org.apache.jasper.runtime.HttpJspBase.service(HttpJspBase.java:97)
javax.servlet.http.HttpServlet.service(HttpServlet.java:802)
org.apache.jasper.servlet.JspServletWrapper.service(JspServletWrapper.java:322)
org.apache.jasper.servlet.JspServlet.serviceJspFile(JspServlet.java:291)
org.apache.jasper.servlet.JspServlet.service(JspServlet.java:241)
javax.servlet.http.HttpServlet.service(HttpServlet.java:802)


Help me please....

Thanks!

mbatchelor
01-11-2006, 05:28 AM
Hi there,

I'm sorry you're having trouble getting the platform going. Could you post your server.xml and the tomcat logs so that we can see what's going on?

Thanks,

Marc

agus.prayudhi
01-12-2006, 12:33 AM
I repeated from the beginning as I thought I might miss some of the steps:
- extract pentaho_j2ee_deployment, pentaho_solutions, and pentaho-data to c:
- build pentaho.war using ant 1.6.5
- explode pentaho.war, open web.xml, and set 'solution-path' to c:\\pentaho-solutions
- copy hsqldb.jar from pentaho_j2ee_deployments/pentaho-third-party and
paste it into tomcat-home/common/endorsed
- add jndi datasource mappings to tomcat-home/conf/server.xml
(Now, DefaultContext's parent is Host)
- execute start_hypersonic.bat and run tomcat server
- paste pentaho.war into tomcat-home/webapps

SampleDataErrorLog.txt contains tomcat logs for
http://localhost:8080/pentaho/ViewAction?&solution=samples&path=getting-started&action=SampleDataQuery.xaction

Errors shown in my browser:
Failed
Error: ConnectFactory.ERROR_0001 - Database connection could not be established to: SampleData (org.pentaho.component.SQLLookupRule)

Debug: Starting execute of samples/getting-started/SampleDataQuery.xaction (org.pentaho.solution.SolutionEngine)
Debug: Getting runtime context and data (org.pentaho.solution.SolutionEngine)
Debug: Loading action sequence definition file (org.pentaho.solution.SolutionEngine)
Debug: audit: instanceId=5fc42b47-8343-11da-a36d-c5effb616365, objectId=org.pentaho.runtime.RuntimeContext, messageType=action_sequence_start (org.pentaho.runtime.RuntimeContext)
Debug: validateComponent validating component org.pentaho.component.SQLLookupRule (org.pentaho.runtime.RuntimeContext)
Debug: Validating component for action SampleDataQuery.xaction (org.pentaho.component.SQLLookupRule)
Debug: Executing action sequence (org.pentaho.runtime.RuntimeContext)
Debug: Executing action definition: Iteration {0}0 (org.pentaho.runtime.RuntimeContext)
Debug: audit: instanceId=5fc42b47-8343-11da-a36d-c5effb616365, objectId=org.pentaho.component.SQLLookupRule, messageType=component_execution_started (org.pentaho.runtime.RuntimeContext)
Debug: execute pre-audit (org.pentaho.runtime.RuntimeContext)
Debug: Setting component log level to DEBUG (org.pentaho.runtime.RuntimeContext)
Debug: Initializing component (org.pentaho.runtime.RuntimeContext)
Debug: executeComponent starting audited execute (org.pentaho.runtime.RuntimeContext)
Debug: execute validation=true (org.pentaho.component.SQLLookupRule)
Error: ConnectFactory.ERROR_0001 - Database connection could not be established to: SampleData (org.pentaho.component.SQLLookupRule)
Debug: Running query - select distinct REGION from quadrant_actuals (org.pentaho.component.SQLLookupRule)
Error: SQLBaseComponent.ERROR_0006 - Could not execute SampleDataQuery.xaction (org.pentaho.component.SQLLookupRule)
Debug: executeComponent finished audited execute (org.pentaho.runtime.RuntimeContext)
Error: RuntimeContext.ERROR_0012 - ActionDefinition for org.pentaho.component.SQLLookupRule did not execute successfully (org.pentaho.runtime.RuntimeContext)
Error: SolutionEngine.ERROR_0007 - Action sequence execution failed (org.pentaho.solution.SolutionEngine)


BurstingErrorLog.txt contains tomcat logs for http://localhost:8080/pentaho/UpdateSampleEmails

Thanks,

Agus http://forums.pentaho.org/archived_att/files/logs.zip

mbatchelor
01-12-2006, 06:55 AM
Could you also post your entire server log (tomcat-home/logs)?

I have a feeling it's in the JNDI setup. I don't believe that, in Tomcat5, you have to specify a factory class in the jndi definition.

Try removing the lines that say:




< parameter >< name >factory< / name >< value >org.apache.commons.dbcp.BasicDataSourceFactory< / value >< / parameter >



Post edited by: mbatchelor, at: 01/12/2006 11:00

Hartley Mays
01-30-2006, 06:23 AM
Hello!

I'm also a new user of Pentaho, and I'm trying to get the 1.0.0 deployment samples working under Tomcat 5.5. I believe I'm having the same problem reported in this thread, and I also tried the last suggestion of removing some lines form the server.xml file. I don't think that that changed the problem nor the symptoms. I'm attaching a zip file with all the logs from Tomcat, and the server.xml file I created. This is on Windows XP.

Thanks,
Hartley http://forums.pentaho.org/archived_att/files/Install100Problem013006.zip

mbatchelor
01-30-2006, 10:54 AM
Hi there.

I'm sorry you're having trouble. I did find relevant information on the Apache website. It seems they've changed the format of the resource definitions in the server.xml. Here's the page:

http://tomcat.apache.org/tomcat-5.5-doc/jndi-datasource-examples-howto.html

Please let us know here if this solves your problems.

Take care,

Marc

crouchm
01-31-2006, 06:33 AM
Hi! Here's how I fixed my datasources in Tomcat server.xml:







The link to apache suggests that the url contain "?autoReconnect=true" after the database name. I could not connect with this information - removed it and it worked fine. Good luck! :)

oops - paste didn't work - sorry! datasource ex. attached. http://forums.pentaho.org/archived_att/files/datasourcefix.doc

Post edited by: crouchm, at: 01/31/2006 10:36

adeshazor
01-31-2006, 10:41 AM
Thanks for the sample. We will get the documentation updated for Tomcat 5.5.

Anthony

Hartley Mays
02-01-2006, 06:31 AM
Good Morning,

Thanks to everyone for the updates. Using the example attachment, I have it working now. It looks like there were major changes in the JNDI format for 5.5.

One final question for now: the sample supplied the update for one of the four definitions. With it in place, things seem to be working so far in the sample applications. Under what circumstances do you need to add the other three sources also?

Thanks,
Hartley

adeshazor
02-01-2006, 12:41 PM
The Quartz data source is needed for scheduling action sequences. The Shark data source is used when using the workflow component. The Hibernate data source is used to manage content generated by the platform.

Anthony