PDA

View Full Version : iReport Version Compatability



freshasp
01-24-2006, 09:11 AM
I am using iReport to create and edit the Jasper Reports jrxml files. However, when I produce a report containing a chart I get compilation errors (it compiled fine within iReport). I can only assume that there is a version compability issue (I am using iReport 0.5.3).

What version of iReport produces jrxml files that are compatible with Pentaho?

Thanks!
Paul

mbatchelor
01-24-2006, 10:24 AM
Actually, I think the incompatibility is on the Jasperreport side, not on the ireport side. Try this - replace the file jasperreports-1.0.0.jar in the pentaho.war/WEB-INF/lib directory with the version of jasperreports you used to build your report.

Please be sure to first delete the jasperreports-1.0.0.jar before copying in the newer jar. I think you'll find that their report definition changed between 1.0.0 and the version you're using right now. Simply replacing this jar should allow the report to run as it does within iReport.

Take care,

Marc

freshasp
01-25-2006, 04:08 AM
Thanks Marc.

I've tried each combination of iReport and the jasperreports-1.x.x.jar and I cannot get a combination that works.

To ensure that it's not my report, I've been using the QuadrantForRegion.jrxml file. I load it into iReport, change the report title and re-save it. When I run the new jrxml file in Pentaho I always get exceptions and the action sequence fails.

For example, if I do this with iReport 0.5.1 and run it against the jasperreports-1.0.0.jar I get the attached stack trace.

What did the Pentaho team use to design the sample reports? Should I switch to BIRT - has it got the same/better charting facilities as iReport?

Any ideas most welcome as deadlines are looming... :(

Post edited by: freshasp, at: 01/25/2006 08:15

freshasp
01-25-2006, 04:14 AM
More complete stack trace to replace previous one attached. http://forums.pentaho.org/archived_att/files/stacktrace2.txt

Post edited by: freshasp, at: 01/25/2006 08:15

mbatchelor
01-25-2006, 06:46 AM
Hi there,

In iReport 0.5.1/lib is the file jasperreports-1.0.1.jar. Replace the jasperreports-1.0.0.jar file in the pentaho.war with the 1.0.1.jar first.

Then, delete all the .jasper files you have in the solution leaving only the .jrxml files. Then, restart your server.

I suspect what's happened is the .jasper files that are in there need to be regenerated with the new version of jasperreports. Give that a shot, and let me know how it goes.

freshasp
01-25-2006, 07:03 AM
Good news - that worked - thanks Marc. I'm pretty sure I tried that combo so, as you say, maybe it was an old .jasper file that was causing the problem.

My own report still errors but at least I have an operational system to work from.

Cheers,
Paul