PDA

View Full Version : Analysis trouble with MySQL



bpfonte
03-08-2006, 09:31 AM
Hi all,

I've been trying Pentaho for a few weeks and I'm building a protoype with my own MySQL stored data. Thanks to the documentation and the forum, I was able to get many features working.

Now I'm trying to set up analysis with Mondrian and JPivot just like the query1.xaction example... with little success! Allways come up to "JPivot Error ... An error happened servicing a JPivot request. Please see the server console for more details." The console doesn't get too much explicit. The first error seems to be "java.lang.RuntimeException: Datasource java:comp/env/jdbc/MySQL is not configured properly".

I've attached a file with my tables definition, xaction and mondrian files so you can see what I'm trying to do and, possibly, identify my mistake.

Meanwhile, I'm needing some pointers so:

1. Which inputs and outputs are really needed in the .xaction file?

2. Both .mondrian and .mondrian.xml are acceptable scema files extensions?

3. I'm using a JNDI specified in /jboss/server/default/deploy/MySQL-ds.xml. It is working with JFreeReports and BIRT. Do I have to make any changes in any other files to make it workwith Mondrian/JPivot?

Sorry for the long post... and many, many thanks in advance for any answers (Double it if your quick : ) )!

Bruno http://forums.pentaho.org/archived_att/files/products.xaction

Post edited by: bpfonte, at: 03/08/2006 13:33

bpfonte
03-08-2006, 09:32 AM
Table definition file http://forums.pentaho.org/archived_att/files/tables.sql.txt

bpfonte
03-08-2006, 09:34 AM
Mondrian Schema file http://forums.pentaho.org/archived_att/files/products.mondrian.xml

Post edited by: bpfonte, at: 03/08/2006 13:34

ocho79
03-08-2006, 11:57 PM
bpfonte wrote:


2. Both .mondrian and .mondrian.xml are acceptable scema files extensions?


As far as I know, only the .mondrian.xml file extension is a valid extension for setting up a cube. Only if you want to edit your Cube-Schema with the workbench you have to rename the xyz.mondrian.xml file to xyz.mondrian. After you have finished editing the file you have to rename it manually again.

bpfonte
03-09-2006, 02:54 AM
You seem to be right. Aditionally, the model tag needs the entire path to the file such as
myteste/products.mondrian.xml.

But still can't analize my MySQL data...

Post edited by: bpfonte, at: 03/09/2006 06:56

ocho79
03-09-2006, 04:03 AM
maybe you can post the referring lines of your logfile ([jboss_dir]/server/default/log/server.log) so we can see where it fails.

Saludos

bpfonte
03-09-2006, 04:14 AM
Thanks for your help...

Here's a file with the errors from server.log when I run product.xaction. http://forums.pentaho.org/archived_att/files/server.log.txt

mbatchelor
03-09-2006, 03:20 PM
Your problem is in the following line in your .xaction file:

<jndi>MySQL</jndi>

You don't have a JNDI datasource bound by the name of MySQL (case is important).

For you to use a datasource in JBoss, you must create an xxxxx-ds.xml that specifies the JNDI name, driver, etc. You also must modify your web.xml (in pentaho.war) to include the resource, and your jboss-web.xml (also in pentaho.war) to specify the jboss-specific datasource de-reference.

Hope this helps,

Marc

bpfonte
03-09-2006, 03:34 PM
Hi,

Thank you for your answer.

I have a MySQL-ds.xml file. It's supplying JNDI connection to various BIRT a JFreeReports I've made so I think it's working.

As for the web.xml and jboss-web.xml modifications, I've tried it without success. Each time I add a new datasource the demo stops working. But I'm going to give it a try again since you say the problem is around there... any hints on how to set it up? I followed closely the dataset examples already in the files.

Thanks,
Bruno

bpfonte
03-10-2006, 04:23 AM
Hi again,

Finally made it. You were right! The problem was solved when I added the datasources to both web.xml and jboss-web.xml carefully! Earlier I hadn't payed enough attention to case and wrote MySql instead of MySQL...

Thanks for a great hint and for a great software,
Bruno