PDA

View Full Version : Remote installation



luker
03-09-2006, 03:02 AM
Hi,
i've installed Pentho on a remote server, when i navigate Pentaho on the server (pointing the browser to localhost), it works, but when i try to navigate it from outside, e.g. from my computer, the homepage appears without images, and when i click on any link the page doesn't display as well, because the browser points to localhost and not to the name of the server.
What does this depends on?

Thanks for your help.

Luker

bpfonte
03-09-2006, 03:35 AM
Hi,

Long way: The answer is on page 5 of the Pentaho_Quick_Start pdf...

Quick way: edit pentaho-demo/jboss/server/default/deploy/pentaho.war/WEB-INF/web.xml. Search for param-name "base-url" and edit the param-value so that it points to your server. eg: http://192.168.0.10:8080/pentaho

Hope this helps,
Bruno

luker
03-10-2006, 12:56 AM
Yes this is the solution, thanks a lot!

mdaleiden
04-14-2006, 12:47 PM
Actually, a better way would be to edit the base-url parameter in web.xml to not even have the server name/port:

<context-param>
<param-name>base-url</param-name>
<param-value>/pentaho</param-value>
</context-param>

I have tested this in JBoss 4.0.3 and it works. Basically, what you are doing is using a relative base URL instead of an absolute one, so the web server will automatically prepend the correct server and port.

Post edited by: mdaleiden, at: 04/14/2006 16:49

mbatchelor
04-14-2006, 05:47 PM
mdaleiden wrote:

Actually, a better way would be to edit the base-url parameter in web.xml to not even have the server name/port:


Unfortunately, that will only work when interacting directly with the server. The problem with this though is when the server has to generate URL's that point back to the server - say for example when generating an e-mail. The baseUrl is used to directly generate these URLs.

bpfonte
04-17-2006, 01:44 AM
Another hint on this...

One problem I had was that I needed to constantly changing the url in order to get it to work when working on my machine, when accessing inside the lan and when showing it on our public ip address.

I solved that:
1. Change the url to http://testbi:8080/pentaho;

2. Added 'testbi' on my router dns list pointing to my ip address. This way any machine who gets its address through dhcp will get the name;

3. Added an entry with 'tesbi' and my ip address on c:/windows/system32/drivers/etc/hosts on windows machines with static ip or outside access;

4. The same entry on /etc/host on Linux machines;

Now anyone who types http://tesbi:8080 on the browser will see my Pentaho!

Post edited by: bpfonte, at: 04/17/2006 05:52