PDA

View Full Version : Error accessing Pentaho 1.1.4



joebordes
04-05-2006, 09:52 AM
Hi,

I had 1.1.3 more or less working well with jboss4.0.3.
I have just updated to 1.1.4 and now get this error when trying to access localhost:8080/pentaho

--------
exception

javax.servlet.ServletException: org.pentaho.system.PentahoSystem.getResourceAsString(Lorg/pentaho/solution/IActionResource;)Ljava/lang/String;
org.apache.jasper.runtime.PageContextImpl.doHandlePageException(PageContextImpl.java:848)
org.apache.jasper.runtime.PageContextImpl.handlePageException(PageContextImpl.java:781)
org.apache.jsp.jsp.Navigate_jsp._jspService(org.apache.jsp.jsp.Navigate_jsp:156)
org.apache.jasper.runtime.HttpJspBase.service(HttpJspBase.java:97)
javax.servlet.http.HttpServlet.service(HttpServlet.java:810)
org.apache.jasper.servlet.JspServletWrapper.service(JspServletWrapper.java:322)
org.apache.jasper.servlet.JspServlet.serviceJspFile(JspServlet.java:314)
org.apache.jasper.servlet.JspServlet.service(JspServlet.java:264)
javax.servlet.http.HttpServlet.service(HttpServlet.java:810)
org.jboss.web.tomcat.filters.ReplyHeaderFilter.doFilter(ReplyHeaderFilter.java:81)

root cause

java.lang.NoSuchMethodError: org.pentaho.system.PentahoSystem.getResourceAsString(Lorg/pentaho/solution/IActionResource;)Ljava/lang/String;
org.apache.jsp.jsp.Navigate_jsp._jspService(org.apache.jsp.jsp.Navigate_jsp:103)
org.apache.jasper.runtime.HttpJspBase.service(HttpJspBase.java:97)
javax.servlet.http.HttpServlet.service(HttpServlet.java:810)
org.apache.jasper.servlet.JspServletWrapper.service(JspServletWrapper.java:322)
org.apache.jasper.servlet.JspServlet.serviceJspFile(JspServlet.java:314)
org.apache.jasper.servlet.JspServlet.service(JspServlet.java:264)
javax.servlet.http.HttpServlet.service(HttpServlet.java:810)
org.jboss.web.tomcat.filters.ReplyHeaderFilter.doFilter(ReplyHeaderFilter.java:81)
-------------

Suse 9.3
Java 1.5
jboss4.0.3

Any ideas?

Thanks, joe

bhagan
04-11-2006, 07:36 AM
Hi Joe,

Some method signatures have changed between 1.1.3 and 1.1.4, so the jsps in your solutions may be out of date. Have you updated your pentaho-solutions and pentaho-data?

Have a great day,
Brian

joebordes
04-11-2006, 02:51 PM
Hi Brian,

Yes, I am almost positive I changed the samble data and solutions directory.

Truth is that I have been making so many changes and tests with this app that I don't really know where I am any more. I have Pivot table working against sample data but I can't get it to work with my database. I am able to execute MDX query against my database/cube. I can't get jasper nor jfree reports working but BIRT seems to be working OK.

The truth is that there are so many places to change things, so many libraries to put into place, etc that this whole app is very intmidating.

I am starting to get a grasp of what is going on and to see the potential, but the learning curve of Pentaho is very steep.

I have decided to try to get it working with 1.1.3 and see if it satisfies my client. Then I will try out whatever version is current. As long as you think the changes aren't worth me trying 1.1.4 again.

Thanks for your reply.

Regards, Joe