PDA

View Full Version : Hello World Email Example



Monica
04-13-2006, 07:39 AM
Hi,

I am getting the following error

Error: Email.ERROR_0011 - SMTP send failed: javax.mail.MessagingException: Could not connect to SMTP host:

I have changed email-config.xml according to the quick start documentation.

Thanks a lot.

bpfonte
04-17-2006, 01:49 AM
Hi,

Can you reach your smtp server? Open a command line and try to ping it.

--
Bruno

Post edited by: bpfonte, at: 04/17/2006 05:50

r.marinho.gomes
05-08-2006, 04:16 AM
Eu também estou com o mesmo problema.
Veja o ping:

C:\\Documents and Settings\\ricardo>ping mail.datatraffic.com.br

Disparando contra webdata.datatraffic.com.br [10.0.1.11] com 32 bytes de dados:

Resposta de 10.0.1.11: bytes=32 tempo

HazMatt
05-09-2006, 01:26 PM
I also cannot get it to work since upgrading from the 1.0 version. I get

Error: Email.ERROR_0011 - SMTP send failed: javax.mail.SendFailedException: Sending failed; nested exception is: class javax.mail.MessagingException: 530 5.7.0 Must issue a STARTTLS command first 19sm6900347nzp (org.pentaho.plugin.email.EmailComponent)

If I roll back to version 1.0, everything works again. Can anyone help?

dmoran
05-10-2006, 12:31 PM
Sounds like you may be using "gmail" as your email server. If that is true, try starting with the email_config_gmail.xml file. Modify this file with your server specific settings and save it as email_config.xml.

It has several property settings required by gmail including:

mail.smtp.starttls.enable = true

which looks like the error message you are getting.

If you are using a different email server, post all the info - Server, version etc and we will try to work out the correct email properties to set.

Thanks,
Doug

HazMatt
05-10-2006, 12:37 PM
I am using gmail and I did use the email_config_gmail.xml file as a starting point. Here is the content of my file.





smtp.gmail.com


587


smtps


true


true


true







divxbiserver@gmail.com


divxbiserver


changeme

HazMatt
05-10-2006, 12:39 PM
looks like the content of the file did not paste properly, so I have attached the file here. http://forums.pentaho.org/archived_att/files/email_config.xml

gargsuman
11-14-2006, 06:15 PM
HazMatt wrote:

looks like the content of the file did not paste properly, so I have attached the file here. http://forums.pentaho.org/archived_att/files/email_config.xml
Hello HazMatt did you find a solution for this problem. I am having this very same issue. If you have solved this issue then please post the reply here so that myself and other can benefit. Thanks

miland
12-24-2006, 08:50 AM
I too am getting the same errors. "Must issue a STARTTLS command first c30sm9173795ana (org.pentaho.plugin.email.EmailComponent)" I can ping smtp.gmail.com with no trouble and I've entered the correct username/password in email-config.xml. Also, backed up the original email_config.xml and saved email_config_gmail.xml as email_config.xml.

What am I doing wrong? :(

bflaster
02-27-2007, 02:13 PM
I also cannot get it to work since upgrading from the 1.0 version. I get

Error: Email.ERROR_0011 - SMTP send failed: javax.mail.SendFailedException: Sending failed; nested exception is: class javax.mail.MessagingException: 530 5.7.0 Must issue a STARTTLS command first 19sm6900347nzp (org.pentaho.plugin.email.EmailComponent)

If I roll back to version 1.0, everything works again. Can anyone help?

Hi all,

I just installed version 1.2.0 (Build 534), and am having this error as well using a g-mail account. I have modified the email_config.xml file as per the instructions for using gmail. The last post in this thread was from two months ago with no listed fix. Has there been a resolution here or is this a bug with 1.2?

Thanx.