PDA

View Full Version : Pentaho en RedHat 9 Problem



mikepre
04-15-2006, 12:13 PM
Hi, being a Windows guy for years, and now getting into Linux and Opensource BI, I'm dealing with a problem that I do not know how to solve.

My notebook, running Windows 2000 Server and VMWare Workstation, has a Virtual machine defined to run Red Hat Linux 9 (the virtual machine was assigned 12 GB Hard Drive, 512 RAM)

On top of that, I installed Pentaho Linux demo (normal installation from .rpm file).

All went OK until I run the shell file to launch Pentaho, I receive a:

[root@localhost pentaho-demo]# sh start-pentaho.sh
start-pentaho.sh: line 10: ./start_hypersonic.sh: Permission denied
start-pentaho.sh: line 12: ./run.sh: Permission denied

No way to start the service. I checked the perimissions to the point I disabled RedHat firewall, I stopped the Apache Server service, but still receive a "no permission" message.

If some other service is using port 8080, I do not figure out how to check it, so any help is appreciated.

I'm using root account, and Pentaho demo was installed from the same account.

Thank you for your help.

Michael Prendergast

mbatchelor
04-15-2006, 01:48 PM
Check your Linux manual for the CHMOD command. I'll bet that there is no Execute permission on those .sh files.

Hope this helps,

Marc

guzaldon
04-15-2006, 03:44 PM
also to check to see if you OS is running things on different ports. use a command you are probably firmilar with which netstat -a will let all the active connections and the ports it's listening on. So that way you can see which what ports the OS is listening on. and to check permissions for files go with a ls -l which is good to use to verify stuff.

Linux is great but it's only great b/c of the great opensource projects like Pentaho as well as the other projects that pentaho as merged with.

I hope that helps a bit.

btw I'm running it on centOS and red hat enterprise linux 4 w/o any problems.

Nic

mikepre
04-17-2006, 04:31 AM
I did it, and yes, it solved the problem to some extent.

Now I get the following error:

./start-hypersonic.sh: line 10: java: command not found
....
Make sure JAVA_HOME points to a JDK and not a JRE
....
It seems that directories are not well referenced or I need to install JRE or JDK, but as per reading installation manuals, everything was included in the pre built demo.

mikepre
04-17-2006, 04:39 AM
Thank you, now I know a way to scan used ports in LInux :)

Regards,

Michael

mbatchelor
04-17-2006, 05:44 AM
The JDK is not included with the RPM we ship for Linux. You'll need to download the JDK, and make sure it's configured for your environment.

I hope this helps,

Marc