PDA

View Full Version : Preconfigured 1.0.0 Dashboard params...



stormmind
07-12-2006, 05:23 AM
I downloaded the preconfigured 1.0.0 release, configured it and the Getting started samples work fine.

In the documentation it said that in the portal_demo, there are dials examples that were linked to the pivot-tables. If I click the dials, I am indeed taken to a window with pivot-table. The problem is that it doesn't matter which dial I pick or what settings (region, department) I have, I am always taken to the same pivot-table showing everything (actual column says "143,639,982.00").

In the url, I see the parameters change:
http://localhost:8080/pentaho/Pivot?solution=samples&path=analysis&action=query1.xaction&position=.[Sales%20Rep]
http://localhost:8080/pentaho/Pivot?solution=samples&path=analysis&action=query1.xaction&position=.[HR%20Generalists]
etc...

I don't see any region though, is it stored in the session maybe?
Anyway, when I check the log (jboss serverlog), I see following:


2006-07-12 15:16:35,809 DEBUG [org.pentaho.repository.filebased.solution.SolutionRepository] SOLUTION-REPOSITORY:: SolutionRepository.DEBUG_FILE - getFile path=C:\\Java\\Pentaho\\pentaho-demo\\pentaho-solutions\\samples\\analysis\\query1.xaction

2006-07-12 15:16:35,819 DEBUG [org.pentaho.repository.filebased.solution.SolutionRepository] SOLUTION-REPOSITORY:: Adding variable source request to parameter region

2006-07-12 15:16:35,819 DEBUG [org.pentaho.repository.filebased.solution.SolutionRepository] SOLUTION-REPOSITORY:: Adding default value of "" to parameter region

2006-07-12 15:16:35,819 DEBUG [org.pentaho.repository.filebased.solution.SolutionRepository] SOLUTION-REPOSITORY:: Adding variable source request to parameter department

2006-07-12 15:16:35,819 DEBUG [org.pentaho.repository.filebased.solution.SolutionRepository] SOLUTION-REPOSITORY:: Adding default value of "" to parameter department

2006-07-12 15:16:35,819 DEBUG [org.pentaho.repository.filebased.solution.SolutionRepository] SOLUTION-REPOSITORY:: Adding variable source request to parameter position

2006-07-12 15:16:35,819 DEBUG [org.pentaho.repository.filebased.solution.SolutionRepository] SOLUTION-REPOSITORY:: Adding default value of "" to parameter position

2006-07-12 15:16:35,819 DEBUG [org.pentaho.repository.filebased.solution.SolutionRepository] SOLUTION-REPOSITORY:: Adding variable source request to parameter mdx

2006-07-12 15:16:35,819 DEBUG [org.pentaho.repository.filebased.solution.SolutionRepository] SOLUTION-REPOSITORY:: Adding default value of "" to parameter mdx

2006-07-12 15:16:35,819 DEBUG [org.pentaho.repository.filebased.solution.SolutionRepository] SOLUTION-REPOSITORY:: Adding variable source request to parameter mode

2006-07-12 15:16:35,819 DEBUG [org.pentaho.repository.filebased.solution.SolutionRepository] SOLUTION-REPOSITORY:: Adding default value of "" to parameter mode

2006-07-12 15:16:35,819 DEBUG [org.pentaho.repository.filebased.solution.SolutionRepository] SOLUTION-REPOSITORY:: Adding variable source response to parameter viewer

2006-07-12 15:16:35,819 DEBUG [org.pentaho.runtime.RuntimeContext] a501ad74-11a8-11db-87a4-533022dc44b2:RUNTIME:context-5244982-1152710195809:query1.xaction audit: instanceId=a501ad74-11a8-11db-87a4-533022dc44b2, objectId=org.pentaho.runtime.RuntimeContext, messageType=action_sequence_start

2006-07-12 15:16:35,819 DEBUG [org.pentaho.runtime.RuntimeContext] a501ad74-11a8-11db-87a4-533022dc44b2:RUNTIME:context-5244982-1152710195809:query1.xaction validateComponent validating component org.pentaho.component.PivotViewComponent


It seems that the parameters aren't getting passed correctly. Any idea what might be wrong?

Thanks!

stormmind
07-17-2006, 12:56 AM
no text