View Full Version : Illegal HTML character

07-25-2006, 03:08 AM
I receive the following when trying to carry out some xactions, e.g. the first report example with custom parameters and most of the Steel Wheels xactions. The result is that nothing is returned. How and where do I go about finding the offending character?


12:37:49,850 ERROR [Logger] Error end:
12:46:30,126 INFO [STDOUT] Error at element constructor <input> on line 103 of
SERE0014: Illegal HTML character: decimal 133
12:46:30,142 ERROR [Logger] Error: Pentaho 1.2.RC1.0 build 341
12:46:30,142 ERROR [Logger] misc-org.pentaho.core.util.XmlHelper: XmlHelper.ERRO
R_0005 - Fehler beim Transformieren: Illegal HTML character: decimal 133
; SystemID: ; Line#: 103; Column#: -1
net.sf.saxon.trans.DynamicError: Illegal HTML character: decimal 133

07-25-2006, 05:09 PM
Hi Ralph,

Thanks for reporting this, Ralph.

It looks like it might be a locale-specific XSL transform error. Can you post the part of the error log that starts

Can you post more of the error message, starting with the part that reads:

ERROR [Logger] Error start:
and ends with

ERROR [Logger] Error end:



07-26-2006, 12:48 AM
Thanks for getting back so fast, James.

The attached nohup.txt contains a fresh start, the first report with parameters try and the stopping of the server. You may have something there - the browser (IE 6) locale is de_DE and we are using translated *_de.properties files. Let me know, if you need anything else or where I can look for the problem.


Post edited by: rlance, at: 07/26/2006 04:49 http://forums.pentaho.org/archived_att/files/nohup.txt

Post edited by: rlance, at: 07/26/2006 04:50

07-26-2006, 05:52 AM
Thanks for the log file, that helps.

1) Can you tell me which sample you were running at the time?

2) Does it work if you try this with the browser set to another locale? I have tried setting my browser to English and cannot reproduce it.

3) Can you send me your translated *_de.properties files. I think the error might be in one of those files. Are those file using \\u encoding for any special characters? If not this might be the problem. If you are editing those files your editor needs to save the file using "ASCII + Universal Character Names" and you will see special characters encoded with \\u00E9 (e.g. see pentaho-solutions/index_fr.properties). You should also be able to use XML character references e.g. &#00E9; but we recommend \\u encoding.

A good editor for editing .properties files for translation is http://www.unipad.org


07-26-2006, 06:48 AM
Here you go, James.

1) The first report sample with parameter (custom-parameter-page-example.xaction). Also the Steel Wheel reports don't display.

2) I set my IE 6 to en-us, saw everything in english, but had the same error in the log.

3) Please see attached file. These have what I think are the correct unicode encodings for the german umlaut chars and the SS char. BTW, the *_de.* files were sent to Gretchen M. a few days ago as a contribution, but without these encodings, so I sent them again today. She's got a JIRA running to have them merged in for the RC. I did *not* save any of these as anything special, just plain o' text. I'll check out unipad.


Post edited by: rlance, at: 07/26/2006 10:50

07-26-2006, 06:55 AM
Sorry, having trouble sending you the zip... http://forums.pentaho.org/archived_att/files/pentaho_demo_de.zip

07-26-2006, 08:01 AM
I pulled down unipad and verified that my unicode values were correct. I let it convert one of the _de.properties files, saved it explicitly as ASCII-UNC and then let a compare program do a diff with the file I had changed with a search and replace tool. They were identical.

BTW, the same problem occurs under our Linux and Win XP Pro platforms with RC and on my XP host, the files haven't been encoded yet. Furthermore, I forced the XP to use my 1.5.7 java SDK and tried again. No change.

The only xaction I can successfully execute from the Steel Wheels group is "Income Statement" that goes direct to PDF.

I don't know if this all helps, but I'm trying to give you as much info as I can.


07-27-2006, 06:45 AM
Thanks for all the information.

The problem seems to be with the default parameter pages. Can you verify that you have not altered ~/pentaho-solutions/system/custom/xsl/DefaultParameterForm.xsl in any way?


07-27-2006, 07:17 AM
All files in this directory on both servers have 20.07.2006 19:07 and have not been altered. I'm sending here a copyas .txt file, so you can compare.

Ralph http://forums.pentaho.org/archived_att/files/DefaultParameterForm_xsl.txt

Post edited by: rlance, at: 07/27/2006 11:19

07-27-2006, 09:50 AM

I was able to reproduce this problem. I switched my Windows XP to German and dropped your _de.properties.

James and I spent a little bit debugging through this and found a problem in one of the resources.

Take a look at your messages_de.properties in the org\\pentaho\\locale package. Look at UI.USER_UPDATE. There is an illegal "dot dot dot" in there. We changed it to a true "..." and it works great.

This simple change should get you going again.


07-28-2006, 06:03 AM
Good work, you two! I didn't know where to look. After I made the changes, everything worked magically. There's a BIG difference between a three dot ellipse char and three dot chars!

BTW, I reported your findings to Gretchen M. She has a JIRA running to have our contributed de.props merged into the distribution. She wrote back that she'll work in this fix.

Thanks alot. Sorry to have put you through this, but you've strengthened our confidence in you all.


Post edited by: rlance, at: 07/28/2006 10:04

07-28-2006, 06:54 AM

Excellent, that is certainly good to hear!