PDA

View Full Version : Integrating BIRT report with my own data



rachaputis
08-09-2006, 11:36 AM
I am trying to evaluate PENTAHO BI PLATFORM for my company. My current task is to integrate JFree, Jasper and BIRT reports into PENTAHO. I was successful with JFree. Now I am trying to figure out how to integrate BIRT.

1. I first tried with BIRT 2.1 (ECLIPSE 3.2) and the error I got was:

Error: BIRT.ERROR_0007 - error running report samples\\reporting\\Sowmya_test.rptdesign - org.eclipse.birt.report.engine.api.EngineException: The design file has error and can not be run. (org.pentaho.plugin.eclipsebirt.BIRTReportComponent)

2. After following some of the messages posted on the forums, thought this should be version problem. So I downloaded BIRT 2.0.1 (ECLIPSE 3.1).

3. I use JDBC connection to connect to my databases and the report was successfully generated in BIRT 2.0.1. It is under:
C:\\Documents and Settings\\srachaputi\\workspace3.1\\sowtest

I copied and pasted two generated files (sowtest.RPTDESIGN, sowtest.PROJECT) under:
C:\\Pentaho\\pentaho_demo-1.2.RC1.341\\pentaho-demo\\pentaho-solutions\\samples\\reporting

4. Created sowtest.XACTION file in Pentaho Design Studio and I used the code that is in 'Creating Pentaho Solutions' version: June 27th, 2006 to modify sowtest.XACTION's code. I included JDBC database source connection in .XACTION file. But with or without JDBC connection in .XACTION file, I do not get any errors but only blank page is getting displayed.


I am sending all the three files (.PROPERTIES, .XACTION and .RPTDESIGN)

Looking forward to some pointers here
Thanks in advance,
rachaputis http://forums.pentaho.org/archived_att/files/sowtest.zip

guzaldon
08-09-2006, 01:00 PM
If you are getting a blank page that means your close most of the time you might want to look at the server logs to see if there is a stack trace in there where you might be able to isolate the problems better.. also in your xaction under the "logging level" change that from "error" to "trace" that way you'll get more info in the log to help you figure out what's up with it.

also I think there is some documentation for birt intergration in the some of the install guides I believe so that might help as well.

But from what I can see most things look good. though I'm not a birt expert by any means.

Good luck you can do it,

Nic

rachaputis
08-10-2006, 06:26 AM
Hello Nic,
1. As you suggested, I checked the server log file. This time I am enclosing the server file as attachment also. Can you please look into the log file and give me some pointers? I looked into it and as far as I interpretted it I think it is not picking up the configuration. What kind of configuration is this? Is this something that needs to do with database?

2. I used to have the default value in the out-put string as pdf and I changed it to html. I also changed the logging-level from 'Error' to 'Trace'

3. As far as I looked into the documentation part, Integrating BIRT Reports -Eclipse BIRT Definitions is found only in 'Creating Pentaho Solutions' Guide. I followed it exactly to the point.

4. If you are not familiar with the BIRT reports is there a way you can check with others? My company is just waiting for results from me so that the tool evaluation is complete and we could proceed further with the licensing part.

Thanks in Advance,
Sowmya.

rachaputis
08-10-2006, 06:27 AM
Had to rename the file. I am sending the file as attachment.
Thanks

Post edited by: rachaputis, at: 08/10/2006 10:29

rachaputis
08-10-2006, 06:31 AM
Sorry Failed to send the zipped file. This time I am sending only one file. server.log file.
Thanks http://forums.pentaho.org/archived_att/files/server1.log

guzaldon
08-10-2006, 09:55 AM
I looked at it and made a couple minor changes. to get it use the sample data in mysql as well as some other changes that to bring up to par take a look can compare them to what you had.

you'll need to change some stuff in the report definition like connection string, data set and the row names. IT's working for me. NOW and I"m not expert at birt. :-p

I'm using
Pentaho BI Platform server is ready. (1.2.0-365 RC2)

It's attached. Let me know if it works for you.

Nic

you'll need to change this:


<data-sources>
<oda-data-source extensionID="org.eclipse.birt.report.data.oda.jdbc" name="Data Source" id="4">
<property name="odaDriverClass">com.mysql.jdbc.Driver</property>
<property name="odaURL">jdbc:mysql://nowell:3306/sampledata</property>
<property name="odaUser">threeg</property>
<property name="odaPassword">PRIVATE</property>
</oda-data-source>
</data-sources>
<data-sets>
<oda-data-set extensionID="org.eclipse.birt.report.data.oda.jdbc.JdbcSelectDataSet" name="Data Set" id="5">
<property name="dataSource">Data Source</property>
<property name="queryText">select CITY, POSTALCODE from OFFICES</property>
</oda-data-set>
</data-sets>
and this

<expression name="valueExpr">row["CITY"]</expression>
</data>
</cell>
<cell id="15">
<data id="16">
<expression name="valueExpr">row["POSTALCODE"]</expression>
back to how you had it. http://forums.pentaho.org/archived_att/files/4sowTachaputis.tar.gz

rachaputis
08-14-2006, 04:42 AM
Hello Nic,
I tried to change the code and still I get the same error. Just wondering if there is a way you could email the .RPTDESIGN, .XACTION, and .PROPERTIES files. I would like to compare and see where I am going wrong.

my email:rachaputis@gmail.com

By the way, I use Pentaho BI server is ready. (1.2.RC1.0-341)

Looking forward to your response,
Thanks in advance,
Sowmya.

rachaputis
08-14-2006, 11:16 AM
Hello Nic,
1. I successfully got connected to sample data using the following info:

Driver Class: org.hsqldb.jdbcDriver (v1.8)
Database URL: jdbc:hsqldb:hsql://localhost/sampledata
User Name: PENTAHO_USER
Password: password

2. It generated the sample report successfully in the Eclipe-BIRT SDK (3.1, BIRT Designer 2.0.1) and my Pentaho server is 1.2.RC1.341.

3. As usual I copied test_sow.rptdesign, test_sow.properties and created the needed .XACTION and tried to display it online. (http://localhost:8080/pentaho). I still get the blank report.

4. I tried to see if I could use the changes you sent me last time.
I needed to know the name of the .JAR FILE to include the DRIVER CLASS - ' com.mysql.jdbc.Driver'. What is the .JAR file name that I could use from the list of .JAR's that is existing in the following path for mysql connection (C:\\Pentaho\\pentaho_demo-1.2.RC1.341\\pentaho-demo\\jboss\\server\\default\\lib)
or What steps do I need to take to connect to the sample data using mysql?


I went ahead and downloaded mysql connector.JAR file. But that did not work either. I get Driver class could not parse 'URL' error.

C:\\Pentaho\\pentaho_demo-1.2.RC1.341\\pentaho-demo\\jboss\\server\\default\\lib\\mysql-connector-java-5.0.3

I tried with both the following information:
<driver>com.mysql.jdbc.Driver</driver>
<connection>jdbc:mysql://localhost:3306/sampledata</connection>
<user-id>jim</user-id>
<password>password</password>


AND


property name= odaDriverClass > com.mysql.jdbc.Driver </property gt>
<property name= odaURL>jdbc:mysql:/ owell:3306/sampledata </property>
<property name= odaUser>threeg </property>
<property name= odaPassword>PRIVATE </property>

Nothing worked. I am sending all my fies as attachment.
I think I am missing something. Not sure what it is. I am just stuck with this error since couple of days. Is there a way you could send your .XACTION, .RPTDESIGN, and .PROPERTIES file that worked for you? so that I could compare where I am going wrong. Any help to make me move forward would be greatly appreciated.

Thanks in advance,
NOTE: If you can please email .XACTION and .RPTDESIGN files to
rachaputis@gmail.com

Sowmya http://forums.pentaho.org/archived_att/files/Test_sow.zip

rachaputis
08-16-2006, 05:36 AM
The issues that I had in integrating BIRT reports was
- I could figure out how to connect to my local database. And I had the problem of connecting to sample data. I looked into report design wizard to get the connection string details.
- I guess I was restarting Pentaho-demo server for every small change
- Looks like the files got corrupted. I had to reinstall Pentaho-demo for it to make it work. BIRT integration was done successfully.

Thanks for all the responses and pointers.
Sowmya