View Full Version : Problems with reports

11-28-2006, 08:35 PM

first of all sorry for my bad english.

I can't make any of my reports work. I'm using the report wizard and everything looks fine in the preview until i deploy them to the server -By the way, when i publish i get an empty message box instead of a message like "publish successful"-.

i'm using a MDX query and graph charts. When i test the reports on the server i always get this error:

[es_161] Error: [es_198] The data object is not an IPentahoResultSet object (org.pentaho.plugin.jfreereport.components.JFreeReportDataComponent)

[es_116] Debug: [es_21] Starting execute of euroidiomas/reportes/Consumos mensuales.xaction (org.pentaho.core.solution.SolutionEngine)
[es_116] Debug: [es_30] Getting runtime context and data (org.pentaho.core.solution.SolutionEngine)
[es_116] Debug: [es_33] Loading action sequence definition file (org.pentaho.core.solution.SolutionEngine)
[es_116] Debug: SolutionRepository.DEBUG_FILE_PATH - [es_35] getFile path=D:\\pentaho1.2\\pentaho-demo\\pentaho-solutions\\euroidiomas\\reportes\\Consumos mensuales.xaction (org.pentaho.repository.filebased.solution.SolutionRepository)
[es_116] Debug: [es_23] Adding variable source request to parameter output-type (org.pentaho.repository.filebased.solution.SolutionRepository)
[es_116] Debug: [es_17] Adding default value of "pdf" to parameter output-type (org.pentaho.repository.filebased.solution.SolutionRepository)
[es_116] Debug: [es_23] Adding variable source request to parameter result-set (org.pentaho.repository.filebased.solution.SolutionRepository)
[es_116] Debug: [es_17] Adding default value of "no-value" to parameter result-set (org.pentaho.repository.filebased.solution.SolutionRepository)
[es_116] Debug: [es_23] Adding variable source response to parameter report (org.pentaho.repository.filebased.solution.SolutionRepository)
[es_116] Debug: [es_34] audit: instanceId=bffd8646-7f61-11db-b854-455997b1c1cd, objectId=org.pentaho.core.runtime.RuntimeContext, messageType=action_sequence_start (org.pentaho.core.runtime.RuntimeContext)
[es_116] Debug: [es_1] validateComponent validating component JFreeReportComponent (org.pentaho.core.runtime.RuntimeContext)
[es_116] Debug: [es_75] Validating component for action Consumos mensuales.xaction (org.pentaho.plugin.jfreereport.JFreeReportComponent)
[es_116] Debug: [es_75] Validating component for action Consumos mensuales.xaction (org.pentaho.plugin.jfreereport.components.JFreeReportValidateParametersComponent)
[es_116] Debug: [es_42] Executing action sequence (org.pentaho.core.runtime.RuntimeContext)
[es_116] Debug: [es_24] Executing action definition: Iteration 0 (org.pentaho.core.runtime.RuntimeContext)
[es_116] Debug: [es_34] audit: instanceId=bffd8646-7f61-11db-b854-455997b1c1cd, objectId=JFreeReportComponent, messageType=component_execution_started (org.pentaho.core.runtime.RuntimeContext)
[es_116] Debug: [es_3] execute pre-audit (org.pentaho.core.runtime.RuntimeContext)
[es_116] Debug: [es_21] Setting component log level to DEBUG (org.pentaho.core.runtime.RuntimeContext)
[es_116] Debug: [es_11] Initializing component (org.pentaho.core.runtime.RuntimeContext)
[es_116] Debug: [es_4] executeComponent starting audited execute (org.pentaho.core.runtime.RuntimeContext)
[es_116] Debug: [es_94] execute validation=true (org.pentaho.plugin.jfreereport.JFreeReportComponent)
[es_116] Debug: [es_94] execute validation=true (org.pentaho.plugin.jfreereport.components.JFreeReportValidateParametersComponent)
[es_116] Debug: [es_75] Validating component for action Consumos mensuales.xaction (org.pentaho.plugin.jfreereport.components.JFreeReportDataComponent)
[es_116] Debug: [es_94] execute validation=true (org.pentaho.plugin.jfreereport.components.JFreeReportDataComponent)
[es_161] Error: [es_198] The data object is not an IPentahoResultSet object (org.pentaho.plugin.jfreereport.components.JFreeReportDataComponent)
[es_116] Debug: [es_15] executeComponent finished audited execute (org.pentaho.core.runtime.RuntimeContext)
[es_161] Error: RuntimeContext.ERROR_0012 - [es_33] ActionDefinition for JFreeReportComponent did not execute successfully (org.pentaho.core.runtime.RuntimeContext)
[es_116] Debug: [es_34] audit: instanceId=bffd8646-7f61-11db-b854-455997b1c1cd, objectId=org.pentaho.core.runtime.RuntimeContext, messageType=action_sequence_failed (org.pentaho.core.runtime.RuntimeContext)
[es_161] Error: SolutionEngine.ERROR_0007 - [es_27] Action sequence execution failed (org.pentaho.core.solution.SolutionEngine)

[es_41] Server Version build 0001

I have now 8 reports and i can't show them to my client. Please help!

Thank you,

11-28-2006, 10:22 PM

Well if you are using publish to server then make sure that you have publish password set for the publisher.

This you can set by editing pentaho-demo\\pentaho-solutions\\system\\publisher_config.xml.
Add a publisher password and use to to publish. Leave pentaho user and password fields as blank.

Also make sure that you have your jndi connection ds file created on the pentaho-demo\\jboss\\server\\default\\deploy.

Once report is published check weather it has created xaction and xml file for report or not.

Other way is to publish via location. publish it to solutions/yourlocation in demo and then refresh repository. Make sure connection-ds.xml is created.

Hope this can solve your problem. If your report is published properly and you have connection defined then it should work.

Pranav Shah

11-29-2006, 07:20 AM
Thank you Pranav for your replay,

i've checked everything you suggested but i'm still getting the same error.

One thing i've noticed is that the path inside the report definition isn't pointing to the right path. I've made the report with the wizard on a machine that is not the server and the path to the mondrian xml file is the absolute path of that pc, not from the server or a relative one.

I've changed the path inside the xreportspec file but nothing...

Thank you,
Jorge Burga

11-29-2006, 08:48 PM

Can you publish report to the local folder and attach xml and xaction files here?

Pranav Shah

11-30-2006, 12:47 PM
Hi Pranav,

This is weird, when i publish using the local option it doesn't generate the xaction file. This is the log from the console:

Writing to ./resources/solutions/samples/reporting/JFreeReport-WizardReport.xml
at org.pentaho.jfreereport.wizard.utility.ActionSequenceUtility.createAc
at org.pentaho.jfreereport.wizard.ReportWizard.generateReportOutput(Repo
at org.pentaho.jfreereport.wizard.ReportWizard.doPublishReport(ReportWiz
at org.pentaho.jfreereport.wizard.ReportWizard.finishFired(ReportWizard.
at org.pentaho.jfreereport.wizard.WizardManager.finish(WizardManager.jav
at org.pentaho.jfreereport.wizard.ui.WizardPanel.widgetSelected(WizardPa
at org.pentaho.jfreereport.wizard.ui.step.ReportSetupPanel.widgetSelecte
at org.pentaho.jfreereport.wizard.ui.swt.PentahoSWTButton.fireSelection(
at org.pentaho.jfreereport.wizard.ui.swt.PentahoSWTButton.mouseUp(Pentah
at org.eclipse.swt.widgets.TypedListener.handleEvent(TypedListener.java:
at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:66)
at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:928)
at org.eclipse.swt.widgets.Display.runDeferredEvents(Display.java:3348)
at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:2968)
at org.pentaho.jfreereport.wizard.ReportWizard.main(ReportWizard.java:16

Am i missing something basic here?

When i publish via server there is no log error. In the action an input String "result-set" from request is passed by. Does the wizard saves the data that will be used on the report?

These are the files generated by option server on the wizard.

thank you,
Jorge Burga http://forums.pentaho.org/archived_att/files/reporting.zip

Post edited by: jburgam, at: 2006/11/30 17:25

11-30-2006, 10:52 PM

By looking at your xaction, xml and mondrian.xml files, It seems like you are using MDX as a data source.

Also, result-set in the input is incorrect as if you have that then it means there is other action which calls your action script or you already have result-set when u run this report.

So look at the samples/reporting folder which has similar jfree-qual reports. See it's xaction file and if you are using SQL query then specify query as per that. If you are using MDX as data source then see samples/datasources example for MDX datasource usage.

Hope this helps. Also I tried to to use report designer (RC3 release) with jfreeQuad tempalte which gives similar errors for me.

May be latest build of report designer work propelry for you. You can build it from SVN or get it from ftp site ftp://community.pentaho.org/client/reportwizard/1.2.0.GA/

Hope this may give you some help.

12-01-2006, 05:15 AM
Thank you Pranav,

I appreciate your help. I'll try with the latest build.

I followed the examples and managed to get my reports work creating them from scratch in the pentaho studio. It requires extra work but at least i can show my reports.

Best regards,

Jorge Burga.