PDA

View Full Version : unpacking files



Anonymous
09-12-2002, 08:48 PM
I'm a student and have been using JBuilder 5 to compile and run my apllications on window.
I have downladed JFreeReport version 0.7.6. I am trying to unpack the jar files but keep getting the error "jar is not recognized as an internal or external command, operable program or batch file".

Please some one help me!!!!

Anonymous
09-12-2002, 09:07 PM
It sounds like you are trying unjar from the command line. You have a couple of choices:

1) use winzip or similar to unpack the archive, or

2) add the jdk to the path; JBuilder does not do this by default.

Hope this helps.

Anonymous
09-12-2002, 10:49 PM
Thanks for the idea of unzipping files which worked but when i tried to run the demonstration application, I typed the following command and it said main class not found


C:\>c:\jbuilder5\jdk1.3\bin\javaw -classpath C:\Documents and Settings\Administrator\My Documents\jfreereport-0.7.6\jfreereport-0.7.6.jar;jfreereport-res-0.7.6.jar;pixie.jar;jcommon-0.7.0.jar;itext-0.94.jar;gnujaxp.jar;bsh-1.2b6.jar com.jrefinery.report.demo.JFreeReportDemo

any help why this happened

Anonymous
09-13-2002, 06:06 AM
I *vaguely* remember reading somewhere that spaces in directory names can cause classpath troubles...so that might be the problem.

Regards,

DG.

Anonymous
09-13-2002, 06:28 AM
Hi,

asside that names with spaces have to be quoted, you are referencing the following files in your classpath:

C:\Documents and Settings\Administrator\My Documents\jfreereport-0.7.6\jfreereport-0.7.6.jar;
c:\jfreereport-res-0.7.6.jar;
c:\pixie.jar;
c:\jcommon-0.7.0.jar;
c:\itext-0.94.jar;
c:\gnujaxp.jar;
c:\bsh-1.2b6.jar

The ';' separates 2 directory entries in the list, entries without an absolute path are made absolute by adding the current working directory to the path definition (so "jfreereport-res-0.7.6.jar" will be transformed to "c:\jfreereport-res-0.7.6.jar" if you start this command from "C:\".

I think this is what you wanted:

c:\jbuilder5\jdk1.3\bin\javaw -classpath "C:\Documents and Settings\Administrator\My Documents\jfreereport-0.7.6\jfreereport-0.7.6.jar";"C:\Documents and Settings\Administrator\My Documents\jfreereport-0.7.6\jfreereport-res-0.7.6.jar";"C:\Documents and Settings\Administrator\My Documents\jfreereport-0.7.6\pixie.jar";"C:\Documents and Settings\Administrator\My Documents\jfreereport-0.7.6\jcommon-0.7.0.jar";"C:\Documents and Settings\Administrator\My Documents\jfreereport-0.7.6\itext-0.94.jar";"C:\Documents and Settings\Administrator\My Documents\jfreereport-0.7.6\gnujaxp.jar";"C:\Documents and Settings\Administrator\My Documents\jfreereport-0.7.6\bsh-1.2b6.jar" com.jrefinery.report.demo.JFreeReportDemo

and if you download start-demo.jar from sourceforge (~450 byte) you can simply type "java -jar start-demo.jar" and java sets its classpath automaticly (the start-demo.jar has to be in the directory ""C:\Documents and Settings\Administrator\My Documents\jfreereport-0.7.6\" for this to work).

Have more fun,
said Thomas

Anonymous
09-18-2002, 01:14 AM
hey its all working..... Thanks alot....You guys are great!!!!!