PDA

View Full Version : Admin unable to log into Spoon



kettle_anonymous
12-18-2005, 02:22 PM
Hi Matt,


Downloaded latest build of Kettle and can't seem to login under the admin id under Windows 2000. Message I receive is "Sorry you don't have permissions to run Spoon". I can see the repository has been built successfully in SQL Server and that the guest and admin ID's are there in the R_USER table.



Any idea what I might be doing wrong?



Thanks



P.S. Connection is via ODBC to MS Sql Server 2005.






Thanks

MattCasters
12-18-2005, 11:05 PM
Hi Anonymous,

To be honest, I never really tried to have a repository under Yukon.
The reason for this is the lack of software. I tried one of the first versions of Express Edition but couldn't get it to work on my Windows XP. Maybe I need to try again.

You did use admin as password, right?

Cheers,

Matt

MattCasters
12-18-2005, 11:06 PM
Oh, and it's always faster to go native.
ODBC is ... well ODBC.

Matt

bwhittaker
05-09-2007, 09:58 AM
user accts are in R_USER, but I get error msg - "Sorry you don't have permissions to run Spoonand Chef". This msg is returned when leave admin password blank. When I put in "admin" as password, I get different error msg - "Incorrect Username or password".


Am using ODBC. I can't get native connection to see repository in any fashion. I have tried the "options" tab using "instance" and "local" as value"

Help

Thanks

Bill Whittaker 240-298-7606

MattCasters
05-10-2007, 03:44 AM
Bill, please check out the SQL Server chapter in the 2.5.0 Spoon documentation.
It describes how to configure the JDBC driver properly.

We use large text/clob fields to store information in the repository and the ODBC drivers don't always handle this properly.

HTH,

Matt

ddepew
07-14-2009, 12:03 PM
I am getting the exact same response as bwhittaker below - Pentaho Data Integration v3.1.2 , SQL Server 2005.

I have successfully implemented the product - all the tables are created in the target MS SQL database - but cannot login. If I try Admin (with no password) it returns 'no permissions', and if I enter the password (I tried the default), it returns 'incorrect username or password'.

Am I missing something?