PDA

View Full Version : select&alter problem in spoon



kettle_anonymous
02-17-2006, 05:27 AM
Attachment: transformation (http://forums.pentaho.org/archived_att/kettle/transformation) hi all
i am facing some problem in the select & alter function of the spoon tool. iam designing a transformation which takes a field (customer_id) from the input and with the help of the select and alter function i am changing it's name to customer_fact.then i putting the data in the final table. but when i run the transformation it is giving me the error as
Select values 2.0 - ERROR : Couldn't find field 'customer_id' in row!


attached is the screenshot of the transformation which i am designing.



if anybody has worked on it and solved it please help me or if anybody can give me any suggestions



thanks in advance



dinesh barua
indore, india

MattCasters
02-17-2006, 12:09 PM
Hi Dinesh,

I added tracker 1569 for this feature request.

In the mean time, consider verifying your transformation. That way you'll know BEFORE runtime what's missing.
Click right on the Table Output step and select "Check selected steps" or press the Verify button, etc.

Take care,
Matt