PDA

View Full Version : Transformation executes only when in preview mode



kettle_anonymous
02-23-2006, 11:45 AM
Hello,


I just downloaded Kettle and it made a very good first impression. Unfortunately I have some problems with my first test transformation. I used the "Copy Table Wizzard" and created simple input/output table steps.



If I try to run nothing happens, the transformation finishes without executing the two steps.



If I run it in previewmode and set the number of rows high enough, then the steps execute and the table is copied.



I tried it with a version stored in the repository as well as an xml saved transformation.



Any pointers towards what the problem could be are very appretiated.



Thanks and regards,



Ingo

MattCasters
02-23-2006, 12:23 PM
vey strange indeed.

Any additional info you can give : platform, versions: anything is welcome.
Can you post the XML of the transformation?

Try this...

- Use Transformation : copy to clipbard
- Open another Spoon window, Transformation paste from clipboard.
- If preview then works, the XML should be OK and you should be able to run it using Spoon or Pan.

Cheers,
Matt

kettle_anonymous
02-27-2006, 01:58 AM
Hi Matt,

I used MySQL as a repository and there seems to be the problem. I downloaded MySQL just a couple of weeks agao therefore it is a farely recent release.

When I restarted spoon without using the repository and recreated the transformation, saving it as xml, it worked like a charme.

When using MySQL as repository I also get the same error that is described in the bug list. (Faulty representation of the transformation when loading from repository) It seems like it is not advisable to use MySQL as kettle/spoon's repository, right?

Thanks for your help!

Regards,
Ingo

jbleuel
02-27-2006, 12:30 PM
Hi Ingo,


again, this seems to be a problem with the boolean (see bug id 1539 http://www.javaforge.com/proj/tracker/itemDetails.do?task_id=1539&navigation=true



Try to get the latest Kettle.jar http://www.javaforge.com/proj/doc/details.do?doc_id=3719



If it is not solved by this, please open a bug.



Thanks a lot & HTH
Jens

kettle_anonymous
03-01-2006, 01:32 AM
Hi Jens,


I opended a bug....using the latest kettle.jar didn't help.



Regards,
ingo