PDA

View Full Version : Version 2.2.2 or 2.3.0, which should be used?



kettle_jgrengbondai
04-12-2006, 10:09 AM
Hello Matt !


Congratulations and good luck to you for your new role at Pentaho.



I'm a little confused about which version of KETTLE we should use. I moved from kettle 2.2.2 to kettle 2.3.0. Not long ago there’s another 2.2.2 after 2.3.0. The Pentaho website does not mention kettle 2.3.0 and I cannot locate 2.3.0 in the SVN source tree.



Should I go back to newer version 2.2.2 instead of version 2.3.0 which is older?



Thanks,



Jules Grengbondai

MattCasters
04-12-2006, 11:01 AM
Hi Jules,

The branches show only archived source trees.
The 2.3.0 version is located in trunk. This is the one to use if you don't mind the development bug now and then ;-)
Of-course, a LOT of bugs in 2.2.2 have been fixed, but I guess a couple of others have been introduced. If you want to play safe, stay with 2.2.2, although nothing shocking is being developed in the trunk at the moment. AND of-course, I guess we could use some more testers.

Version 2.3.0 is certainly not older, we have reached 1104 commits over the last 30 days!

Hope this helps,
Matt