PDA

View Full Version : ERROR : Column Index out of range, 2 > 1



kettle_anonymous
04-26-2006, 07:12 AM
Howdy agian,
I got a few more things knocked out of my transactions. no I just have a problem with insorting them into my fact table I keep getting this error:


insert into facts.0 - ERROR : Because of an error, this step can't continue:
insert into facts.0 - ERROR : Couldn't get row from result set
insert into facts.0 - ERROR : Column Index out of range, 2 > 1
be.ibridge.kettle.trans.Trans - ERROR : Errors Detected



Something that I have tried putting a sort infront to force it to wait a bit long b4 processing, but it didn't seem to do much. it only take about 2 minutes to hit the error so it's running reasonably fast.



the only thing I'm can thing of is the not null statements for columns. since it appears to miss a couple FK's when I preview a select, but when I preview the Deminsion it then toss that error anyway.



Any suggestion what I might be doing wrong. if you need more info let me know.



THanks,



Nic

guzaldon
04-26-2006, 07:20 AM
btw I'm using the jar for kettle 2.3


Nic

MattCasters
04-26-2006, 07:29 AM
Nic,


This is a SQL/database problem (http://www.google.be/search?hl=nl&q=%22Column+Index+out+of+range%22&meta=)
Don't know much about the specifics of your situation so that's all I can say ;-)



All the best,



Matt

guzaldon
04-26-2006, 07:33 AM
thanks for pointing me in the right direction.
I'll report back with what I find.


Nic

guzaldon
04-26-2006, 08:50 AM
after looking into a couple things. I found something that is kind of wierd.


When I run my transaction and I don't have the "update dim" check box checked. I get some interesting results on my preview as well as disceting the log details at rowlevel. Namely the first two results appear to have the wrong auto incromental numbers when compared to the the values that already excite in the DB. so I'm not sure that that's the problem, but after the first two results I see in the preview that all other values for that feild are then 1.0. So I'm going to try and delete the rows it's trying to use and see if that still yeilds the same results.



Any Ideas out there of maybe how to work around this?



Thanks,



Nic

guzaldon
04-26-2006, 09:09 AM
just a few notes


even after removing the ones that it was trying to use Still have the same problem. So i guess it's back to the drawing board.



So I was testing some of my past transactions that worked and now part of a former on is toss the same error on a different deimension all together.



Nic

guzaldon
04-26-2006, 09:24 AM
I dropped kettle back down to 2.2.2 and I didn't have the problem anymore. I will investigate a bit more to verify.


Just some more info.



Nic

MattCasters
04-26-2006, 11:15 AM
Keep me informed please. 2.3.0 should be completely backward compatible. If it is not, it's a bug.

Thanks,

Matt

guzaldon
04-26-2006, 11:39 AM
I just got done running my transactions to update my deminsions and then to update my facts. with the 2.2.2 jar and I didn't get any errors and everything was processed smoothly.

I'm running the 2.3 jar now. I will report back when I'm done with that.. but I'm pretty sure based on my results earlier that I'm going to get a column index out of range error agian.

I did find some resource were people were running into this problem with java when using preparedStatements in a multi threaded applications.

well while I was writing this up I did get the errors of column index out of range on two SCD but not on the other 3.

It's kind of weird, but if I can supply with anything to help you find the cause of this I'll be more than happy to. just let me know what you need and I'll do my best to get it to you..

its the least I could do to try and make a sweet app like kettle better. Here at my company we are all about trying to give back to the Open Source Communities.

I hope it helps and if there is anything you need such as log files of 2.2.2 and 2.3 running on the same data with the transaction in question I can probably get them too you.

Thanks for the help Matt,

Nic

MattCasters
04-26-2006, 11:57 AM
Nic,

Thank you for the feedback. I would like to know more about the problem you're facing.
Anything you can give me is welcome. Even after all these mails I still don't know anything about your situation.
Most important:
- What database are you running on?
- What step(s) are you using?
- Can you send me the XML of the transformation you have problems with? With this I can try to reproduce the problem over here.
- The log files with the exact errors will indeed help.

If you feel like it, log a bug for this too (trakcers), that way your name is on it ;-)

Thanks in advance!

Matt

guzaldon
04-26-2006, 12:17 PM
I just drop them to you in an email.

I'll log a bug in a couple minutes.

Glad I can be of help.

NIc