PDA

View Full Version : No-drillable Dashboards



nankel
01-28-2007, 02:59 PM
Hi everybody,

A fast one,

I want to know how can i avoid the possibility of drill in a dashboard, i mean for instance in a pie chart , i dont wanna for the slices to be clickable.

I supposse it has to be a parameter or something.

It will be very useful for me for future developments.

Thanks in advance, and greetings from (a cold) Spain.

Un saludo.
Alvaro.

roth
01-29-2007, 03:33 AM
Hi

Try playing around with Pivot.jsp. There are several visibility flags you can set to false to not have it display certain parts, i.e. the toolbar. I have also seen an 'editable' flag, maybe that's what you need.

There might also be another way to achieve what you need, I don't know.

Cheers,
Tobias

jagiaz
01-31-2007, 01:53 PM
Hello Roth,

Thanks for your answer, but I think that's not the problem that nankel has (well I actually know, he works with me :) ).

The problem is, that the charts generated by the pentaho API (method ChartHelper.doChart(....)) are always drillable, always have somekind of hyperlink, and we don't want them to have it. I'm talking about the charts in a JSP dashboard, of course.

So far this is probably a very easy thing to do, only that we haven't, at the moment found how :(

Regards,
Javier

aparna_dev
06-05-2008, 11:31 AM
Hi,

I'm facing the same problem.

Did you find a solution? I need to disable the drill downs.

Thank you,

Aparna.

ingo.klose
06-05-2008, 11:39 AM
Hi,

you can try in the chart attributes:

<is-clickable>false</is-clickable>


If that doesn't work, create a dummy JS function in the JSP-page and set the url-template to link to it. That way nothing happens if the user clicks on the chart.

Regards,
Ingo

pmalves
06-05-2008, 12:50 PM
I didn't find a way to make it non clickable (need to try that method). What I usually do is to pass the anchor '#' as the url-template, no need for dummy js functions

Mark Renton
06-09-2008, 12:42 PM
When I write the atributte
<paramName>revenue</pramName>
in the widget.xml

the drill down is disabled :eek:

pmalves
06-09-2008, 12:57 PM
I don't use widget.xml files, so not sure how to do it...

dherzog
06-09-2008, 01:19 PM
http://forums.pentaho.org/showthread.php?t=57053


I had the same problem; passing a "void" inner-param seems to work for me.

If anyone has a better/more official way of disabling click throughs I'd love to hear it.

-d-

aparna_dev
06-10-2008, 02:31 AM
I tried <is-clickable>false</is-clickable> and passing # in the drill url, neither worked!!!

But when i add <paramName>revenue</paramName> in the widget xml, it works surprisingly..disabling the drill down from the chart.

Strange!! But m happy something worked. Thanks Mark. :D

Regards,
Aparna.

raju
09-23-2008, 02:06 AM
After a long struggle to disable the url , found this post. it really worked. thanks :).. but i cant understand how it cuts down the url. thanks