PDA

View Full Version : Help.. !!



dcsk
02-05-2007, 04:15 PM
Widget.ERROR_0001 - Could not create widget display

Server Version 1.2.0 build 398 RC2


here buy i aready attach my jsp, xaction and xml file in the NEED HELP.zip

Please Help me.. really appriciate it...

dgambin
03-07-2007, 08:13 AM
Hi,

I have a similar problem with this error using my own data, but it only happens when clicking on a particular pie slice

Any help?

regards, dejan

pabbott
01-14-2008, 10:15 AM
I had a similar problem while migrating from Pentaho 1.5.3 to Pentaho 1.6.0. After spending some time debugging through Pentaho code I discovered that the problem was in the data being returned by my XAction. I was using a Time Series graph that expected to get 3 columns, but my XAction only returned 2 columns, the first column was missing.
The TimeSeriesCollectionChartDefinition.setDataByColumn() method assumes that its got 3 columns of data and that the first column is a String the second is a Date object and the third is a Number object. BUT it doesn't check the object's type before casting it.
In my case there were 2 columns, a Date and a BigInteger, this resulted in a ClassCastException, but as I hadn't passed a logger into the ChartHelper.doChart() I didn't see this exception.

It would be helpful to users if TimeSeriesCollectionChartDefinition.setDataByColumn() did some data validation before trying to use it.

santos_g15
04-15-2008, 04:04 AM
hey your xml didnt contain chart type which is essential property.then if you want to use Time sereis chart you got to have the first coloumn as string ,second column as date(to_char doesnt return date as date object it returns it as string object i guess) third column has to be numeric value.try the changes .