PDA

View Full Version : Frustrated with NoClassDefFoundError



mika
04-18-2007, 03:48 PM
I am doing a feasability study on using Pentaho dashboard in our application but I am struck with following error when I am trying to use ant generated pentaho.war for tomcat. I am using 1.5 version. Actually I tried both 1.2 and 1.5 version but the same error and i have seen other posts with the same problem but no solution. Is anybosy using Pentaho with Tomcat or its just a myth.
I get following error and I think I get this when ever it tries to access the database (hypersonic).

java.lang.NoClassDefFoundError org.pentaho.repository.runtime.RuntimeRepository.setSession(RuntimeRepository.java:75) org.pentaho.core.system.PentahoSystem.getRuntimeRepository(PentahoSystem.java:1148) org.pentaho.core.solution.SolutionEngineBase.execute(SolutionEngineBase.java:198) org.pentaho.core.solution.SolutionEngineBase.execute(SolutionEngineBase.java:164)

Robsteranium
04-19-2007, 04:25 AM
Are you setting-up a dashboard based upon (e.g.) the sample dashboard?

You may have overspecified your jsp in the web.xml

You don't need to duplicate all the references to dashboard because some refer to a precompiled class.

See this thread for more info...