PDA

View Full Version : ERROR_0021 - Could not detemine implementor for IAclVoter



mika
04-18-2007, 06:22 PM
I am getting the following error while trying to run Pentaho on Tomcat, can somebody please throw some light on this. I am getting this error while starting Tomcat, so I think its some configuration that I am missing.

18:16:42,264 ERROR [Logger] misc-org.pentaho.core.system.PentahoSystem: PentahoS
ystem.ERROR_0021 - Could not detemine implementor for IAclVoter

18:16:42,264 ERROR [Logger] misc-org.pentaho.core.system.PentahoSystem: PentahoS
ystem.ERROR_0021 - Could not detemine implementor for ISubscriptionRepository

sauli
05-09-2007, 06:35 AM
I'm new to pentaho and I also struggled with this one for a while. My fix was to add to the pentaho.xml a class that implements IAclVoter.

example:
<objects>
.
.
<IAclVoter scope="global">com.pentaho.security.acls.voter.PentahoAllowAnonymousAclVoter</IAclVoter>
</objects>

dfx25
09-14-2009, 04:15 PM
I find the file but, sorry where i have to paste this line.

or i don't know if is the pentahoObjects.spring.xml file where i have to paste it..? :confused:

Somebody could help me !!!