PDA

View Full Version : after secure filter a parameter appears twice in the request



xsabatea
05-22-2007, 07:06 AM
Hi all,

I have a problem with a sort of xaction that uses the secure filter component. When I set the "output type" by request (p.e type=html) before the secure filter page, the param appears twice in the url after the secure filter execution. If I don't set the "output type" by request, the xaction works like a charm with the "output type" default value.

That's what happens:

first url:
.../ViewAction?&solution=samples&action=action_file.xaction&path=reporting&type=pdf

second url:
.../ViewAction?&?&type=pdf&P1=20&solution=samples&action=action_file.xaction&path=reporting&type=pdf

here secure filter add P1 value and "type" again. With the type parameter twice in the URL , the JasperReport component complains about report type:

Error: JasperReport.ERROR_0011 - Report output type is not 'html' or
'pdf' (org.pentaho.plugin.jasperreports.JasperReportsComponent)

If I avoid to set the output type in the request the xactions works fine with a warnning about the "output type":

first url:
.../ViewAction?&solution=samples&action=action_file.xaction&path=reporting

second url:
.../ViewAction?&?&P1=20&solution=samples&action=action_file.xaction&path=reporting&type=pdf

Warnning message:
2:48:45,550 WARN [JasperReportsComponent] f8b29b7e-0851-11dc-a66e-d1316fc7b6b2 COMPONENT: context-7512560-1179830907210:action_file.xaction [es_235] No output was specified, using default output stream. This usage will not be supported in the
future. Please modify this action sequence.

the xaction is attached for further details.

Has anybody a explanation for that?
Why a parameter is added twice in the request after the secure filter execution?

Thanks in advance!

xsabatea
05-24-2007, 04:52 AM
Moving to a newer version (1.2.1.625) fixs the problem.