PDA

View Full Version : config security service, ?



acimi
06-08-2007, 07:21 PM
Hi All,
I have created a metadata file using the metadata editor.
1. How do I publish it to pentaho server 1.5.3 ?. I could, however, create an xmi file.

2. I can see metadata.xmi file in the samples folder. When I open WAQR, there are no available business views. If this is an issue, how can I fix it?. When I click on Go>New Report - I can see a big scroll of errors on the console starting with a nullpointer exception.
(I tried saving my xmi file in the samples folder, which didnt work)

3. Finally, config security service - What should be specified here?

Thanks in advance for any help!
AL

MattCasters
06-09-2007, 04:38 AM
The XMI needs to be saved in the samples folder as "metadata.xmi"
You can also create another folder next to "samples", make it a solutions folder by putting index.xml in it and then put the metadata.xmi in it.
Please see the original sample metadata.xmi for the security settings.

All the best,

Matt

acimi
06-09-2007, 09:44 AM
Hi Matt,
Thanks for your help
1. Ok, I have a working folder next to samples with index.xml. I renamed my xmi file to metadata.xmi and moved into that folder.

2. I figured the security settings from samples\metadata.xmi and made appropriate changes. Thanks!

3. Neither of the above files show in WAQR. Any ideas whats going wrong? I could never see "samples\metadata.xmi" in the WAQR. I am always logged in as Joe, I even tried restarting Pentaho.

4. When I click on Go>New Report - I can see a big scroll of errors on the console starting with a nullpointer exception - is that indicative of something?


Thanks again,

Al

MattCasters
06-09-2007, 01:51 PM
You need to give your domain/models rights to user Joe. Did you do that?

acimi
06-10-2007, 10:06 AM
Matt,
I could configure the security service and after clicking load, I can see the users and roles.
I edit the business properties model, under security information I could add joe as owner with execute rights.
In the xmi file, the owner-rights tag is -
<CWM:Description xmi.id = 'a902' name = 'security' body = '&lt;security&gt; &lt;owner-rights&gt; &lt;owner&gt;&lt;type&gt;user&lt;/type&gt;&lt;name&gt;joe&lt;/name&gt;&lt;/owner&gt; &lt;rights&gt;1&lt;/rights&gt; &lt;/owner-rights&gt; &lt;/security&gt; '
type = 'Security'>

Does that give you any clues why its still not working?

Thanks!
Al

MattCasters
06-10-2007, 03:38 PM
Hi Al,

I'm ashamed to say that there are plenty of reasons why it could still bork.
However, did you create categories using the categories editor?
You have to specify the columns you want to expose to your users.
Please note that the Adhoc tool still has an issue in 1.5M3 with that, but at least you should see it appear.
If that still is not working, give the 1.5M4 a go. It should pop up for download later this week.

All the best,

Matt