PDA

View Full Version : creating a metadata repository in SQL DB



douglaspsmith
07-05-2007, 11:10 AM
Hi,
I'm trying to create a repository in a postgres DB. I have configured the repository.properties file in the jdbc directory but I get the following

org.pentaho.pms.core.exception.CWMException: CWM.ERROR_0002 - Error getting a handle on the repository.
...

Caused by: org.pentaho.pms.core.exception.CWMException: CWM.ERROR_0003 - Unable to get repository implementation for class [org.netbeans.mdr.persistence.jdbcimpl.JdbcStorageFactory].
at org.pentaho.pms.core.CWM.getRepository(CWM.java:486)
... 13 more
Caused by: org.netbeans.mdr.util.DebugException: Failed accessing storage factory.

What am I doing wrong?

Thanks in Advance.
Doug

douglaspsmith
07-06-2007, 08:38 PM
I found my problem. typo in repository.properties.

rlance
10-01-2007, 07:38 AM
Hi Doug,
I'm having the same errors while trying to implement the Derby DB. Could I ask you what the typo actually was?
Thanks,

rlance
10-05-2007, 12:05 PM
I got around my problem.

meussram
09-18-2008, 12:55 PM
Hi there,

I know this is old stuff but I had the same issues:
- My metadata editor was opening on 'There are no models defined...' een though I created and saved some the day before, which I was able to view in the reporting web service client

=- When trying to save new Connections/Models I was getting: 'CWM.ERROR_0002' Unbale to get a handle on the repository...

Unable to delete mdr tree... That kind of stuff.

My only problem was that when I had created my previous connections and models I was logged as root, and when I logged the next time on my pentaho machine it was as 'AUser'.

The discrepancy hosed the metaeditor. It's probably trivial for many, but I tought I'd share this since it took me half a day to figure it out...