PDA

View Full Version : Problem starting RC2



xpt
09-21-2007, 03:30 PM
Hi,

I'm trying pentaho_demo_hsqldb-1.6.0-RC2.820 under Windows XP.



To start the server on a Windows computer, navigate using Windows explorer to the 'pentaho-demo' directory, and double click the 'start-pentaho.bat' file.


I first tried

pentaho_demo_hsqldb-1.6.0-RC2.820.tar.gz

but there is no

'start-pentaho.bat' file under the 'pentaho-demo' directory, only the .sh version available.

I then tried the

pentaho_demo_hsqldb-1.6.0-RC2.820.zip

but there is not a single file under under the 'pentaho-demo' directory, let alone start-pentaho.*.

So I tried to double click on

pentaho-demo\jboss\bin\run.bat

but this is what I get:



===============================================================================
JBoss Bootstrap Environment
JBOSS_HOME: C:\WINDOWS\pentaho-demo\jboss
JAVA: java
JAVA_OPTS: -Dprogram.name=run.bat -Xms128m -Xmx512m -XX:MaxPermSize=256m -Dsu
n.rmi.dgc.client.gcInterval=3600000 -Dsun.rmi.dgc.server.gcInterval=3600000
CLASSPATH: C:\WINDOWS\pentaho-demo\jboss\bin\run.jar
===============================================================================
java.lang.UnsupportedClassVersionError: javax/management/NotificationEmitter (Un
supported major.minor version 49.0)
at java.lang.ClassLoader.defineClass0(Native Method)
at java.lang.ClassLoader.defineClass(Unknown Source)
at java.security.SecureClassLoader.defineClass(Unknown Source)
at java.net.URLClassLoader.defineClass(Unknown Source)
at java.net.URLClassLoader.access$100(Unknown Source)
at java.net.URLClassLoader$1.run(Unknown Source)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(Unknown Source)
at java.lang.ClassLoader.loadClass(Unknown Source)
at java.lang.ClassLoader.loadClass(Unknown Source)
at java.lang.ClassLoader.loadClassInternal(Unknown Source)
at java.lang.ClassLoader.defineClass0(Native Method)
at java.lang.ClassLoader.defineClass(Unknown Source)
at java.security.SecureClassLoader.defineClass(Unknown Source)
at java.net.URLClassLoader.defineClass(Unknown Source)
at java.net.URLClassLoader.access$100(Unknown Source)
at java.net.URLClassLoader$1.run(Unknown Source)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(Unknown Source)
at java.lang.ClassLoader.loadClass(Unknown Source)
at java.lang.ClassLoader.loadClass(Unknown Source)
at org.jboss.system.server.ServerLoader.createServer(ServerLoader.java:2
86)
at org.jboss.system.server.ServerLoader.load(ServerLoader.java:268)
at org.jboss.Main.boot(Main.java:194)
at org.jboss.Main$1.run(Main.java:508)
at java.lang.Thread.run(Unknown Source)
Press any key to continue . . .


PS, my java:



C:\>java -version
java version "1.4.1_01"
Java(TM) 2 Runtime Environment, Standard Edition (build 1.4.1_01-b01)
Java HotSpot(TM) Client VM (build 1.4.1_01-b01, mixed mode)


This is my first post. please help.

thanks

xpt
09-21-2007, 03:35 PM
but there is not a single file under under the 'pentaho-demo' directory

only 'jboss' directory is there.

mlowery
09-21-2007, 04:57 PM
The Pentaho Pre-Configured Install v1.6 requires Java 5.

codek
09-24-2007, 07:03 AM
if you dont have start_pentaho.bat in the root directory it sounds like your zip is either corrupt, or has failed to extract correctly?

also like the above poster said - need java 5 as well.

xpt
09-25-2007, 10:57 AM
if you dont have start_pentaho.bat in the root directory it sounds like your zip is either corrupt, or has failed to extract correctly?

also like the above poster said - need java 5 as well.


thanks codek & mlowery for the reply.

Yes. I found out the extraction was failed mystically.

As for the java version, which Pentaho Pre-Configured Install can work with java version "1.4.1_01"?

Sorry if it is obvious, but I'm just so new and still am overwhelmed by the amount of information available, and still disoriented about the web pages...

thanks

codek
09-25-2007, 11:27 AM
afaik no PCI will work with Java 1.4 i'm afraid!

xpt
09-25-2007, 11:36 AM
thanks for the fast respond!

will the Pentaho Pre-Configured Install v1.6 works with Java Version 6 Update 2?

codek
09-25-2007, 12:05 PM
err, not sure - i suggest you get an official reply from Pentaho on that one.

What i do know is that some of the "tools" e.g. the report designer dont work perfectly with 1.6...

mlowery
09-25-2007, 01:25 PM
The only piece of the latest Pre-Configured Install (PCI) that requires Java 5 is JBoss. You could still run the latest BI Server by installing your own JBoss (that runs on Java 1.4) and downloading the Pentaho J2EE deployments package. That being said, the PCI is much easier. So I would recommend upgrading Java if possible. Otherwise, you could download a 1.2.x PCI.