PDA

View Full Version : Pentaho error



deepak.sethy
10-15-2007, 04:35 AM
The following errors were detected
One or more system listeners failed. These are set in the pentaho.xml under the node <system-listeners>.
Error while trying to execute startup sequence for org.pentaho.plugin.eclipsebirt.BirtSystemListener

Please see the server console for more details on each error detected.

jayvpatel
05-14-2008, 05:38 AM
The following errors were detected
One or more system listeners failed. These are set in the pentaho.xml under the node <system-listeners>.
Error while trying to execute startup sequence for org.pentaho.plugin.eclipsebirt.BirtSystemListener

Please see the server console for more details on each error detected.

any solution for this problem

bugg_tb
05-14-2008, 05:46 AM
If you don't need birt reporting switch off the system listner. Worked fine for me

Erki
05-14-2008, 07:52 AM
I have tried restarting the server after comment the listeners, but I still got the same error.
Any other idea?

Where can I finde the server console?


/ erki

bugg_tb
05-14-2008, 08:10 AM
a) I don't believe you if you switched off the listener and the same listener is still causing problems at startup you haven't switched it off

b) what server console?

Erki
05-14-2008, 08:42 AM
Where do I then switch them off?
I deleted them from pentaho.xml.

/erki

bugg_tb
05-14-2008, 08:46 AM
<system-listeners>
<globalObjects>org.pentaho.core.system.GlobalObjectInitializer</globalObjects>
<!-- Insert system-listeners -->
<shark>org.pentaho.plugin.shark.SharkSystemListener</shark>
<!-- <birt>org.pentaho.plugin.eclipsebirt.BirtSystemListener</birt>-->
<jfree-report>org.pentaho.plugin.jfreereport.JFreeReportSystemListener</jfree-report>
<kettle>org.pentaho.plugin.kettle.KettleSystemListener</kettle>
<mondrian>org.pentaho.plugin.olap.MondrianSystemListener</mondrian>
<quartz>org.pentaho.plugin.quartz.QuartzSystemListener</quartz>
<metadata>org.pentaho.plugin.mql.PMDSystemListener</metadata>
<!-- To change the version check frequency, modify the element
version-check-config / repeat-interval-seconds below.
To disable the version checker, set the element
"version-check-config / disable" to true or remove this
system listener.
-->
<version-checker>org.pentaho.plugin.versionchecker.VersionCheckSystemListener</version-checker>
</system-listeners>


Something like that?

If you disable the birt listener you shouldn't get birt listener errors at startup. That doesn't mean you wont get different errors, check carefully

pabloym
11-05-2008, 11:37 PM
el problema esta en la carpeta conf de tomcat, en el archivo server.xml, quizas lo configuraste antes del host con algo asi:
<Context path="/pentaho" docbase="webapps/pentaho/">
<Manager className="org.apache.catalina.session.PersistentManager" saveOnRestart="false"/>
<Resource name="jdbc/prueb" auth="Container" type="javax.sql.DataSource" maxActive="20"
maxIdle="5" maxWait="10000" username="root" password="x" validationQuery="Select 1"
factory="org.apache.commons.dbcp.BasicDataSourceFactory" driverClassName="com.mysql.jdbc.Driver"
url="jdbc:mysql://ocalhost:3306/prueba" testOnBorrow="true" testWhileIdle="true" timeBetweenEvictionRunsMillis="10000"
maxEvictableIdleTimeMillis="60000"/>
<Resource name="jdbc/bd1" auth="Container" type="javax.sql.DataSource" maxActive="20"
maxIdle="5" maxWait="10000" username="pentaho_user" password="x" validationQuery="Select 1"
factory="org.apache.commons.dbcp.BasicDataSourceFactory" driverClassName="com.mysql.jdbc.Driver"
url="jdbc:mysql://ocalhost:3306/bd1" testOnBorrow="true" testWhileIdle="true" timeBetweenEvictionRunsMillis="10000"
maxEvictableIdleTimeMillis="60000"/>

</Context>

yo identifique que el porblema esta ahi, pero no se porque es aun. saludos