PDA

View Full Version : classpath and libsvm



ivo
11-29-2007, 05:53 PM
Hello

sorry to ask this again but I still have problems getting libsvm into my classpath:
1. I put it into the environment variables with 1,2 and 4 backslashes. simple CLI shows that it is not expanded.
2. I put it as a placeholder into the runweka.ini. Simple CLI again shows now instead of %classpath% a #classspath# :mad:

My runweka.ini looks lik this:


classpath=C:\\\\Programe\\\\Weka-3-5\\\\libsvm.jar
# setups (prefixed with "cmd_")
cmd_default=javaw -Xmx#maxheap# -classpath "#CLASSPATH#;#wekajar#" #mainclass#
cmd_console=cmd.exe /K start cmd.exe /K "java -Xmx#maxheap# -classpath \"#CLASSPATH#;#wekajar#\" #mainclass#"
cmd_explorer=javaw -Xmx#maxheap# -classpath "#CLASSPATH#;#wekajar#" weka.gui.explorer.Explorer

# placeholders ("#bla#" in command gets replaced with content of key "bla")
# Note: "#wekajar#" gets replaced by the launcher class, since that jar can
# be provided as parameter


maxheap=1024m
mainclass=weka.gui.Main

Simple CLI sais:


...
file.separator: \
java.awt.graphicsenv: sun.awt.Win32GraphicsEnvironment
java.awt.printerjob: sun.awt.windows.WPrinterJob
java.class.path: #CLASSPATH#;.\weka.jar
java.class.version: 50.0
java.endorsed.dirs: C:\Programme\Java\jre1.6.0_03\lib\endorsed
java.ext.dirs: C:\Programme\Java\jre1.6.0_03\lib\ext;C:\WINDOWS\Sun\Java\lib\ext
java.home: C:\Programme\Java\jre1.6.0_03
...

Does some kind soul have a hint?

Thank you
-ivo

PS.: i'm running weka on WinXp.

ivo
11-30-2007, 06:12 AM
ok, after hours of clueless trying following worked:

I've inserted following line at the end of my weka.ini:

CLASSPATH="c:\\\\Programme\\\\Weka-3-5\\\\libsvm.jar"

Best regards
-ivo