View Full Version : Application error while starting PDI

01-30-2008, 02:39 PM
I have a persistant message when I try to start Pentaho version 3.0+

The message in the 1st error pane is:

String index out of range: 0

When I look in details I find the following errorstack

java.lang.StringIndexOutOfBoundsException: String index out of range: 0
at java.lang.String.charAt(String.java:558)
at org.pentaho.xul.swt.menu.MenuChoice.<init>(MenuChoice.java:43)
at org.pentaho.di.ui.spoon.Spoon.addMenuLast(Spoon.java:1160)
at org.pentaho.di.ui.spoon.Spoon.addMenu(Spoon.java:1033)
at org.pentaho.di.ui.spoon.Spoon.init(Spoon.java:549)
at org.pentaho.di.ui.spoon.Spoon.createSpoon(Spoon.java:5329)
at org.pentaho.di.ui.spoon.Spoon.run(Spoon.java:5667)
at org.pentaho.di.ui.spoon.Spoon.main(Spoon.java:371)

I have tried reinstalling the application, it is installed directly under my c-drive and I also tried moving the application. According to this message I would be inclined to look at the menu definition, but when I remove the ui folder, PDI continues to start and fails at the message above. I have Windows2k with 2GB memory and a 3Ghz Pentium D processor.

What am I doing wrong?


03-29-2008, 06:05 PM
Does anyone know of a fix/workaround for this, please?

I do have DI 3.0.2 running on an XP machine and 2.5.2 did work on my Win2003 server but since installing 3.0.x on Win2003 I have been receiving this error.

Thank you.

03-30-2008, 05:39 PM
No idea actually, but when I start getting symptoms like yours, one of the first things I look at is the Java versions.

04-03-2008, 05:41 PM
Thanks for the reply. I have uninstalled both Java and removed Kettle DI on both my Win2003 and WinXP Pro machines (hardware is more or less identical). I have also compared the enviroment variables in both cases I then re-installed both Java and DI.

On XP, no problem. On Win2003, the message still appears. I am using jre1.6.0._05 in both cases.

Any further suggestions would be appreciated.

04-03-2008, 06:20 PM
I just downloaded 2.5.2 to the Win2003 machine. Changed nothing else. (See my previous message in thread.) It works just fine. 3.0.2 still gives the same error. These things are tricky, I know, but it really does appear to have to do with some bad chemistry involving the 3.0.2 implementation and Win2003.

Any ideas?

Thank you very much in advance.

04-04-2008, 03:58 AM
I have just been able to install DI3.0.2 without particular difficulties on a second Win2003 system (this one vitual, VMware, though I don't think this is relevant to the problem at hand). It would seem that my previous guess about the Win2203 and DI302 "chemistry" was incorrect/premature. Both Win2003 systems have the same Java version 1.6.0_05 installed.

This certainly does rule out a number of hypotheses but I still don't have a clue about the reason for the persistent error on the first Win2003 machine.

Once again, thanks in advance for any input.

04-04-2008, 04:01 PM
Did you install at the same location on both machines.

Also, I noticed the messages in the error log point to xul, Is it possible that the xul libraries are not being loaded (which is the Mozilla widget libraries).?

04-05-2008, 10:34 AM
Thanks for the hint but still no change in the situation. In fact I zipped over the whole kettle directory from the machine where things are working over to the machine where it is failing. I am still receiving the same error.

It makes no difference where I put the directory.

I am not fully certain I understand what you mean about the xul "libraries": the only thing I find regarding xul are a couple of XML-like text files which appear to have to do with menus in Pentaho and ffjcext.xul in the Mozilla extension directory, registered with some_ID/chrome/content/ffjcext. This is the same (except of course the 'some_ID' part) on both Win2003 machines. Sorry but I wouldn't know how to tell if they are "being loaded" on one machine but not the other... :-(

04-06-2008, 12:15 AM

I had a similar problem, though not with Pentaho, but for another application. This happened due to the problem with long and short application names.

Java 1.6 had a few severe compatibilty problems, so my advice would be to stick to Java 1.5, till some workaround is deviced.

04-09-2008, 04:12 PM
Thanks for the hint.

Unfortunately, removing Java 6 and returning to 5 (update 15) hasn't changed anything.

Hard to believe that myself and the person who started this thread are the only ones seeing this. Is anyone there at Pentaho that might have a clue?

Thanks again in advance.

04-09-2008, 04:39 PM
Unfortunately, removing Java 6 and returning to 5 (update 15) hasn't changed anything.

I still maintain therefore that this is related to XUL.

Look at your spoon startup file.

I don't know windows, but for example, in my spoon.sh. I have these two lines:
export MOZILLA_FIVE_HOME=/usr/lib/mozilla-firefox/

Where I pointed MOZILLA_FIVE_HOME to my firefox installation. I don't see this in the .bat file, but perhaps try searching for this.

04-11-2008, 04:56 PM
Thanks for the hint about this part of things. I can't judge what role XUL may or may not be playing here. The .bat file in Windows has nothing about XUL that I can understand or see. I've searched through all the files I can looking for some or all of the strings shown in the details of the error message and find some inside a .jar but don't know what to make of that fact.

The strangest thing--and, I think, the key to understanding all this--is that DI 302 works fine on another Win2003 I use. The Java version is the latest on that machine 1.6_05. I've checked the enviroment variables, too, and the difference is not there. There has got to be something going on on this one machine that DI 302 (30x, for that matter) doesn't appreciate but DI252 doesn't care about. (That is, DI252 works just fine.) By the way, both machines are "patched" with the same MS updates for security, etc.

I'll continue looking to compare differences but any other guesses are appreciated.

04-23-2008, 06:23 PM
Hello. I posted my last reply on April 11. I would like to keep this alive as I don't have any solution.

Can anyone offer up a suggestion along lines that haven't been pursued as of yet?

Thanks in advance.

09-26-2008, 02:13 PM
Take a look at this forum entry:

09-26-2008, 02:17 PM
Try clearing out your persisted settings. On windows these will be found in: C:\Documents and Settings\yourusername\.kettle

Delete the .kettle folder then start kettle again. Kettle will recreate the folder and related files.

This solved the issue for me.