PDA

View Full Version : problem to publish to server with Metadata Editor



grenatdu55
03-17-2008, 11:31 AM
Hello,

I have a problem when I try to publish a Model on the Pentaho Server.

Here are the informations I use :

Publish Location : samples
Web Publish URL http://localhost:8080/pentaho/RepositoryFilePublisher
Publish password (i set it in the config xml file) : password
server userid: joe
server password : password


My problem is that when i click on ok, i have this message :
unable to save file (metadata.xmi) to server. Correct any server, id , or password erros and try again.


But I don't understand what is the problem, because the informations on server userid, password,... seem to be good.

Someone could help me please ?

Thank

wseyler
03-18-2008, 09:58 AM
Are you getting any other errors in the server console?

grenatdu55
03-19-2008, 05:55 AM
Thank for the answer.

In fact the port number of the server was not the good :D

Binayak
04-11-2008, 12:23 AM
Thank for the answer.

In fact the port number of the server was not the good :D

I am facing the same problem. Can you please specify where to specify the port number ?

achaudhry
04-15-2009, 09:54 PM
Hi all,

I'm having the same issue. i.e.

Using
Publish Location : samples
Web Publish URL http://localhost:18080/pentaho/RepositoryFilePublisher (http://localhost:18080/pentaho/RepositoryFilePublisher)
Publish password (i set it in the config xml file) : 12345678
server userid: joe
server password : password


My problem is that when i click on ok, i have this message :
unable to save file (metadata.xmi) to server. Correct any server, id , or password erros and try again.

I have two instances of Tomcat on my machine. The one used for pentaho uses 18080. HELP!

carey
04-21-2009, 04:55 PM
Hello,

I have a problem when I try to publish a Model on the Pentaho Server.

Here are the informations I use :

Publish Location : samples
Web Publish URL http://localhost:8080/pentaho/RepositoryFilePublisher
Publish password (i set it in the config xml file) : password
server userid: joe
server password : password


My problem is that when i click on ok, i have this message :
unable to save file (metadata.xmi) to server. Correct any server, id , or password erros and try again.


But I don't understand what is the problem, because the informations on server userid, password,... seem to be good.

Someone could help me please ?

Thank


HAve you found an answer to this, I came across the problem yesterday, and have not been able to find a solution.

carey
04-21-2009, 06:35 PM
Hi all,

I'm having the same issue. i.e.

Using
Publish Location : samples
Web Publish URL http://localhost:18080/pentaho/RepositoryFilePublisher (http://localhost:18080/pentaho/RepositoryFilePublisher)
Publish password (i set it in the config xml file) : 12345678
server userid: joe
server password : password


My problem is that when i click on ok, i have this message :
unable to save file (metadata.xmi) to server. Correct any server, id , or password erros and try again.

I have two instances of Tomcat on my machine. The one used for pentaho uses 18080. HELP!


I solved my issue similar to yours. I am a Pentaho Newbie but many years in open source and IT in general. Too many hours searching for this solution, then I saw it in a post here http://forums.pentaho.org/showthread.php?t=66711

Apparently you cannot publish to samples as is suggested. I created another solution manually and I was able to publish to that location.

nemiga
09-06-2013, 06:44 AM
I had similar problem - the issue was that max_allowed_packet setting on MySQL was set too small.

For troubleshooting I recommend looking in pentaho.log (assuming that login/password credentials are OK).