PDA

View Full Version : Error con Birt



ravamo
03-25-2008, 04:20 AM
Hola a todos:

Estoy haciendo un Informe en Birt que tiene parámetros y ya he hecho la xaction(según he visto en internet) pero a la hora de ejecutarlo me sale el siguiente mensaje :

[es_161] Error: BIRT.ERROR_0005 - [es_19] The report parameters could not be set up (org.pentaho.plugin.eclipsebirt.BIRTReportComponent)

Al principio pensé que era por no actualizar Birt y lo actualice siguiendo el siguiente HowTo:

1) dowload and extract birt-runtime-2.2.2.zip
2) delete content of pentaho-solutions\system\BIRT\configuration
3) delete content of pentaho-solutions\system\BIRT\plugins
4) copy birt-runtime-2_2_2\ReportEngine\configuration in pentaho-solutions\system\BIRT\configuration
5) copy birt-runtime-2_2_2\ReportEngine\plugins in pentaho-solutions\system\BIRT\plugins
6) delete of pentaho\WEB-INF\lib the next files:

chartengineapi.jar
com.ibm.icu_3.4.4.1.jar
commons-cli-1.0.jar
commons-codec-1.3.jar
coreapi.jar
dataadapterapi.jar
dteapi.jar
engineapi.jar
js.jar
flute.jar
modelapi.jar
org.eclipse.emf.common_2.2.0.v200606051102.jar
org.eclipse.emf.ecore_2.2.0.v200606051102.jar
org.eclipse.emf.ecore.xmi_2.2.0.v200606051102.jar
sac.jar
scriptapi.jar

7) copy content of birt-runtime-2_2_2\ReportEngine\lib in pentaho\WEB-INF\lib

pero nada ,alguien sabe como solucionar esto.

adjunto la xaction por si hace falta.

PD: Si hay algo muy mal o un error muy gordo en otro aspecto se agradece que se me comunique , pues llevo solo 2 meses en este mundo .

Gracias Adelantadas