PDA

View Full Version : security setup



bugg_tb
04-30-2008, 10:59 AM
I'm using Metadata editor for the first time and my pentaho server has our local Active Directory authentication setup, which works fine.

When you add the url like suggested in the security setup it bombs



Unable to get security XML information back from URL [ http://netl:8080/pentaho/ServiceAction?action=SecurityDetails&details=all ]


When I paste the url into a browser and authenticate I get:




The XML page cannot be displayed Cannot view XML input using XSL style sheet. Please correct the error and then click the Refresh (javascript:location.reload()) button, or try again later. Whitespace is not allowed at this location. Error processing resource 'http://netl:8080/pentaho/ServiceAction?action=Securi...
<user>c.savage</user><user>l.corness</user><user>k.kitching</user><user>a.nother&l...




Editing our LDAP entries(if that is the problem) isn't a solution as I don't have control over them. Any other suggestions?

Cheers

Tom

jlangley
02-19-2009, 11:27 AM
Same issue for me using custom Oracle tables for authentication. When accessing the url via the browser (http://reports-dev.ariasystems.net/pentaho/ServiceAction?action=SecurityDetails&details=all) I get properly formatted XML back.

When using the Metadata editor (2.0.0.0345), I get a Null Pointer:
java.lang.NullPointerException
at org.pentaho.pms.schema.security.SecurityService.getUsers(SecurityService.java:461)
at org.pentaho.pms.schema.security.SecurityReference.toXML(SecurityReference.java:99)
at org.pentaho.pms.ui.security.SecurityDialog.test(SecurityDialog.java:531)
at org.pentaho.pms.ui.security.SecurityDialog$5.handleEvent(SecurityDialog.java:285)
at org.eclipse.swt.widgets.EventTable.sendEvent(Unknown Source)
at org.eclipse.swt.widgets.Widget.sendEvent(Unknown Source)
at org.eclipse.swt.widgets.Display.runDeferredEvents(Unknown Source)
at org.eclipse.swt.widgets.Display.readAndDispatch(Unknown Source)
at org.eclipse.jface.window.Window.runEventLoop(Window.java:820)
at org.eclipse.jface.window.Window.open(Window.java:796)
at org.pentaho.pms.ui.MetaEditor.editSecurityService(MetaEditor.java:3820)
at org.pentaho.pms.ui.MetaEditor$26.handleEvent(MetaEditor.java:557)
at org.eclipse.swt.widgets.EventTable.sendEvent(Unknown Source)
at org.eclipse.swt.widgets.Widget.sendEvent(Unknown Source)
at org.eclipse.swt.widgets.Display.runDeferredEvents(Unknown Source)
at org.eclipse.swt.widgets.Display.readAndDispatch(Unknown Source)
at org.pentaho.pms.ui.MetaEditor.readAndDispatch(MetaEditor.java:818)
at org.pentaho.pms.ui.MetaEditor.main(MetaEditor.java:3602)

bugg_tb
02-19-2009, 11:36 AM
I dunno what version of the server you are running. But I've upgraded to BI 2.0.0.stable and the same metadata editor as you and its now running fine.

Tom

jlangley
02-19-2009, 11:48 AM
I'm on biserver-ee-2.0.1-GA.

bugg_tb
02-19-2009, 11:49 AM
No Idea then :)